Cannot Connect on Ethernet or SSH


#1

Brand new to pimusicbox, tried Rune and Volumio also. Despite the device showing as attached in my router’s settings (as and a wired device) i cannot get the web interface to load, nor can I SSH as the connection is refused. Really strange, had no issues with Rune or Volumio.

I’m not sure what else to try? I’ve tried re-writing the SD card many times with no different result.

I’d welcome any suggestions that might allow me to progress past a browser that refuses to load! :slight_smile:


#2

Have you enabled ssh in the settings.ini?


#3

Have the same issue with a new installon RPi3. Yes, ssh is enabled oc.
Workaround was to enable WIFI there is no problem.

Checking the eth0 config reveals, that there is no IPv4 address assigned, which might be an issue.

No such problem on a RPi1B installation, which only has ethernet.


#4

I have the same problem, no way to access the Pi even though it shows up in the connected device list of the router. I have assigned a set IP address, there are no error messages when I connect the TV as a screen (I want to use the TV for the speakers). I have no WiFi dongle so I can’t use the workaround. SSH is set to true in ipconfig. Using an ethernet cable to connect the Pi. When trying to SSH from Ubuntu terminal (wireless connection on same LAN) get ‘no route to host’ message. As far as I’m aware I am not using a firewall or VPN. I’m really out of ideas.

Please help?

Edit: dhclient -v eht0 gives: ‘No DHCPOFFERS received. No working leases in persistent database - sleeping’


#5

Check your /etc/network/interfaces
and make sure it contains

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

Maybe you also need to add a route via your router. Example for 192.168.0.1, your settings may differ:

ip route show
ip route add default via 192.168.0.1 dev eth0

Having those configurations made it work for me.