Boot loop - Enabling DTOverlay Pi-DAC+


#1

Hi there,

I’m completely stuck with this, I get constant restarts when I power on my Pi 3 with Musicbox 0.7.0RC5 with an IQaudIO Pi-DAC+ connected.

musicbox_startup.log:

************************
Initializing MusicBox...
************************
Setting sound configuration...
* Found internal device: card0
    HDMI output detected
* Found internal device: card0
    HDMI output detected
* Found unknown device 'iqaudiodac' on card1
* Found internal device: card0
    HDMI output detected
* Found internal device: card0
    HDMI output detected
* Found unknown device 'iqaudiodac' on card1
Enabling Device Tree Overlay 'iqaudio-dacplus,unmute_amp' and rebooting to activate...
Card=  i2s=  output=iqaudio_dacplus  usb=1  intc=0
No output was specified/found, falling back to auto detection
Card=1  i2s=  output=usb  usb=1  intc=0
Using audio card1 (usb)

Shortly after this it restarts the Pi, only to repeat it again. Any help appreciated, I can’t get to SSH or anything else right now due to the boot looping, when I first flash Musicbox with analog, there’s no issue, this starts (understandly) the moment I tell it to use the DAC+ from the webgui.

Thanks.


#2

Hi, this looks to be a bug in our audio script for this card. It’s looking for “qaudiodacplus” but only finding “iqaudiodac” so then keeps trying to enable it. I can have a fix to try shortly if you are interested.


#4

That would be great if you can.


#5

Hey any word of a workaround for this? I’d really like to use the DAC if possible, fully understand you’re probably very busy.


#6

Hey all,

I have the exact same problem. Would be very nice if there could be a workaround / fix. I enjoy using Musicbox.


#7

Apologies I’ve been away the last few days and I’ve not had a chance to
test (well, simulate, as I don’t have the hardware) the change I made. I’m
back tomorrow at which point I’ll provide the update and you can just try
it out. But you will need to get out of the loop first so perhaps make a
fresh sd card and don’t select the soundcard yet.


#8

No problem, thanks for coming back to me, happy to reflash to test out any workarounds/fixes you have.


#9

I’m having exact same issue with IQAudio board. I’ve dropped back to RC4 + IQAudio workaround for now, but would be great to have a fix for RC5.

Many thanks, and keep up the great work!

Jason.


#10

OK, again, sorry for not providing this last week like I originally said. Please try the following:

wget -O /opt/musicbox/setsound.sh https://raw.githubusercontent.com/pimusicbox/pimusicbox/develop/filechanges/opt/musicbox/setsound.sh

Then select the Pi-DAC+ like usual through websettings or editing settings.ini and reboot.


#11

Thanks for this! It worked, I can use the DAC now.


#12

Also worked for me - Pi-DigiAMP+ now selected and working with RC5 :smile:

Thanks!


#13

Thanks both for testing, appreciated.


#14

I can also boot now, but the system does not support my Allo Boss DAC. I can select it in the web interface but it does not play, probably because the firmware is not present in /boot/overlays.

It does not help to copy from https://github.com/raspberrypi/firmware/tree/master/boot/overlays (not compatible with Wheezy??).


#15

Hi @clriis thanks for the report. I wouldn’t expect there to be a compatibility problem there, those files should all be fine with the kernel in RC5. I will look into this but I will need some help to test the fix, I guess nobody has tried that dac before now.


#16

Thanks for the fast response. I shall certainly be available for helping in testing though my Linux skills are wanting :blush:.

After copying the driver I did check with <aplay -l> and the device did not appear, but the entry in /boot/config.txt seems correct.

There is a thread here about setting up the device: https://forum.modmypi.com/technical-support/allo-boss-raspberry-pi-master-dac-t1369-20.html


#17

Ohh, and I forgot: The device plays (very well) in Volumio and RuneAudio…


#18

Well your initial investigation was spot on the money. It seems the Allo Boss DAC driver (+ some others) were added 9 days after I last updated the driver files (RC4 on March 21st). Which was a bit of bad luck.

I’m going to cut another release with an updated kernel which will include all these drives and the latest kernel. I assume the RPI firmware is still fully supported by Wheezy so you can probably just run rpi-update and get the latest files but I won’t be able to test that myself until tomorrow (hopefully).

EDIT: tracking this at https://github.com/pimusicbox/pimusicbox/issues/395#issuecomment-334312269


#19

@clriis, if you want to test this out, login and run the following commands:

apt-get update && apt-get install --yes rpi-update
PRUNE_MODULES=1 SKIP_WARNING=1 rpi-update
reboot

#20

@kingosticks,

I did the following with image: musicbox_v0.7.0RC5

> wget -O /opt/musicbox/setsound.sh https://raw.githubusercontent.com/pimusicbox/pimusicbox/develop/filechanges/opt/musicbox/setsound.sh
> apt-get update && apt-get install --yes rpi-update
> PRUNE_MODULES=1 SKIP_WARNING=1 rpi-update
> reboot

Then selected my DAC (Allo Boss) in the web interface and rebooted

And SUCCESS…it does play and very well

Thanks,

I’ll be back with more after exploring your applicatoin.

Thanks again


#21

Had the same issue and this fixed it for me as well - thanks
IQAudio Pi-DigiAMP+