ANNOUNCEMENT: Mopidy Mobile 1.8.0 Android Beta


#1

Mopidy Mobile v1.8.0 for Android is now available as public beta on the Google Play store.

It’s been quite some time since the last update to Mopidy Mobile (or MoMo, as it’s sometimes called affectionately), and several third-party dependencies had to be upgraded as well, so joining the Beta testing program is probably more important than ever!

So, what’s in for you if you join the Beta testing program:

  • Added Music Controls plugin (giving you access to Mopidy from your device’s lock screen).
  • Added option to share log messages (for nagging the developer more conveniently).
  • Configurable hardware volume key step .
  • Updated cover art archive logo :wink:

If you choose to install Mopidy Mobile v1.8.0 Beta, please feel free to post any comments or issues either here or on GitHub

Enjoy,
Thomas


#2

Good job. I’ve been using this for the last month with no problems. Music Controls works well. :+1:


#3

Nice app works smoothly once I’ve entered manually entered the server address - it doesn’t seem to pick up any of the 4 instances of Mopidy I have running. How do I check if Zeroconf is running?
From my point of view, trying to use it with Snapcast it would be much easier if it would recognise the ‘hostname.local’ save me going to the router each time I reboot any of them to check ip address.


No servers found on Mopidy Mobile
#4

Thanks for the feedback! There are several free ZeroConf browser apps available on the Google Play store - if any of them is able to find your Mopidy instances, this should work in MoMo, too.
I’m also using hostname.local without problems, though I heard there may be issues with Android 4.4.


#5

Thanks for the quick reply, I’ve installed ZeroConf Browser and it doesn’t find the Mopidy pi’s,
Can you tell me how do I turn on ZeroConf in Mopidy, the only instances of it I can find if I run
’sudo mopidyctl config’ are
’zeroconf = Mopidy MPD server on $hostname’
zeroconf = Mopidy HTTP server on $hostname
is this correct or do I need to change something else?


#6

If I remember correctly you need to install avahi-daemon and python-dbus.


#7

Correct again, thanks a lot!!

avahi-deamon was already installed so it was
sudo apt-get update
sudo apt-get install python-dbus
sudo reboot
that was required.
Momo then picked it up straight away.
Is it mentioned in the docs anywhere, I did a search for ZeroConf but couldn’t find any instructions to make sure python-dbus was installed?


#8

I’m not sure it is, that would be a good addition. Also not sure what section it belongs in though.


#9

In the Debian package for mopidy-2.1.0-1 it’s not listed as a dependency (or even a Recommends), either. Though Mopidy can run fine without python-dbus (and therefore without zeroconf), I’m also a little confused about this - didn’t notice until now, since mopidy-dleyna requires python-dbus anyway.
Maybe @jodal can shed some light on this…


#10

I think it makes sense to list it as a recommended extra.


#11

Hi Tkem, are you using hostname.local on an android phone? I have been trying to use an app called Raspberry SSH and it will only recognise the IP address. The same happens in MoMo, if I manually add kitchen.local it will not connect but the IP address does.

I’m using android 5


#12

With MoMo, I can use both hostname.local and plain hostname. However, I guess this will also depend on your router settings - can’t remember if I set .local explicitly as local domain suffix on my dd-wrt based R7000. I’d try a ping from a desktop machine connected to your local network first…


#13

I can ping using .local or ip address from my laptop or iphone to any of the 3 Pi’s I have running. I can also ping from the Pi’s to each other using either .local or IP address, but from android I can only ping using IP address.
It could be because I am using a Virginmedia “superhub” as router, I think it might be a bit limited in it’s scope.

I’ve asked similar question on Raspberry pi forum and answers have varied from changing the DNS in the wifi settings (its set to go to google by default) or that Ahavi and bonjour aren’t supported by android so it won’t work.
It seemed an obvious thing that they would all talk to each other, I should have known better :laughing:

I think I will set static IP address instead!!


#14

I don’t know if that’s relevant, but I do use static IPs, but not configured on the Pi, but on my router using MAC address mapping. Much more convenient than having to set this up separately on all machines, IMHO.


#15

Good idea - that would certainly be easier than doing each Pi. Thanks