Alexa-controlled media server through Rasp Pi 3 (Problems/Help)


#1

Hi, i’m trying to create a media server that can be controlled through my Alexa, but i cant get the media-box-modify client working, as i plan to use this to communicate with Alexa.

The IP never changes from 127.0.0.1… tho im not create with networking.

Data:

INFO Starting Mopidy 2.1.0
INFO Loading config from builtin defaults
INFO Loading config from /home/pi/.config/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: mpd, http, stream, m3u, local-images, softwaremixer, file, musicbox_webclient, local
INFO Disabled extensions: none
INFO Starting Mopidy mixer: SoftwareMixer
INFO Starting Mopidy audio
INFO Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
INFO Audio output set to "autoaudiosink"
INFO No local library metadata cache found at /home/pi/.local/share/mopidy/local/library.json.gz. Please run mopidy local scan to index your local music library. If you do not have a local music collection, you can disable the local backend to hide this message.
INFO Loaded 0 local tracks using json
INFO Starting Mopidy core
INFO Starting Mopidy frontends: MpdFrontend, HttpFrontend
INFO MPD server running at [::ffff:127.0.0.1]:6600
INFO Starting GLib mainloop
INFO HTTP server running at [::ffff:127.0.0.1]:6680

Thanks!


#2

I’m not familiar with this.

And this isn’t pimusicbox so I have moved it.

The answer you are probably looking for is in the big warning right at the top of https://docs.mopidy.com/en/latest/ext/http/