Using Mopify with Pi Musicbox


I am just playing with Pi Musicbox again and tried to install Mopidy-Mopify (

Unfortunately, it somehow broke the musicbox webserver. I can neither access musicbox nor mopidy-mopify anymore.

Do you have any hints for installing extensions like Mopidy-Mopify on Pi Musicbox?

Thanks for your help!

################ Additional Information
When I log in to musicbox using ssh and start mopidy, the following happend:

root@Kueche:~# mopidy --config /home/mopidy/.config/mopidy/mopidy.conf 
INFO     Starting Mopidy 1.0.0
INFO     Loading config from builtin defaults
INFO     Loading config from /home/mopidy/.config/mopidy/mopidy.conf
INFO     Loading config from command line options
INFO     Enabled extensions: mopify, spotify, mpd, http, stream, spotify_tunigo, mobile, podcast-gpodder, local-sqlite, youtube, podcast-itunes, http-kuechenradio, softwaremixer, local-whoosh, simple-webclient, moped, m3u, websettings, local, tunein, soundcloud
INFO     Disabled extensions: alsamixer, gmusic, scrobbler, subsonic, somafm, internetarchive, musicbox_webclient, dirble, podcast, audioaddict
WARNING  Found alsamixer configuration errors, the extension has been automatically disabled:
WARNING    alsamixer/control must be set.
WARNING    alsamixer/card must be set.
WARNING  Found musicbox_webclient configuration errors, the extension has been automatically disabled:
WARNING    musicbox_webclient/musicbox unknown config key.
WARNING  Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO     Starting Mopidy mixer: SoftwareMixer
INFO     Mixer volume set to 85
INFO     Starting Mopidy audio
INFO     Starting Mopidy backends: SpotifyTunigoBackend, TuneInBackend, StreamBackend, M3UBackend, LocalBackend, SoundCloudBackend, YoutubeBackend, SpotifyBackend
ERROR    Uncaught exception
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/mopidy/", line 274, in run
    backends = self.start_backends(config, backend_classes, audio)
  File "/usr/local/lib/python2.7/dist-packages/mopidy/", line 352, in start_backends
    config=config, audio=audio).proxy()
  File "/usr/lib/python2.7/dist-packages/pykka/", line 93, in start
    obj = cls(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/mopidy_tunein/", line 23, in __init__
    backend=self, timeout=config['tunein']['timeout'])
  File "/usr/local/lib/python2.7/dist-packages/mopidy_tunein/", line 32, in __init__
    self._scanner = scan.Scanner(min_duration=None, timeout=timeout)
TypeError: __init__() got an unexpected keyword argument 'min_duration'
INFO     Stopping Mopidy frontends
INFO     Stopping Mopidy core
INFO     Stopping Mopidy backends
INFO     Stopping Mopidy audio
INFO     Audio output set to "alsasink"
INFO     Stopping Mopidy mixer
  • Mopify installed tornado when installing.
  • I am using Musicbox 0.6
    fresh install

Musicbox is on mopidy 0.19.x, Mopify requires at least 1.0.x So it likely pulled in a new Mopidy and you now have a bunch of extensions that aren’t up to date for 1.0 which had API changes.

I think someone wrote a quite guide on upgrading musicbox to mopidy 1.0, but can’t seem to find it.

Thanks for your answer, good point!
I am just reinstalling musicbox now and then will try to pin the Mopidy-Mopify Version to 1.3.2 which seems to support Mopidy 0.x

Will report my progress when it worked/failed.

I think it’s in the Musicbox repo wiki.

Was a compatible version of mopify not already installed on the v0.6 image?
It should have been.

Thanks for all your answers! I now did the following with a fresh musicbox 0.6:

sudo apt-get install build-essential python-dev 
sudo pip install Mopidy-Mopify==1.3.2

seems that tornado needs those to compile, not sure if really necessary

In the mopidy.conf:

  • Enable Mopify
  • Disable the Musicbox webclient
  • Disable all other extensions which could interfer with mopify

That worked so far. I can now access mopify.

Unfortunately, it is painfully slow. I don’t know what the reason is, htop says that the CPU is not used 100%, I am connected with LAN Cable to the local network but i have a lag of about 5 seconds from a click to an action. Will investigate further…

Is there any progress there @ulilicht with the modifications that you made? Is Mopify any faster now?

Hi @NiPi, I’m sorry I didn’t investigate anymore