Want to access Mopidy via mopidy.local

I access Mopidy through I want to be able to use http://mopidy.local instead. What do I need to configure? I use Raspbian and avahi ist installed and running.

First off, note that Android devices do not understand .local addresses.

The simplest way would be to change your hostname to mopidy, have iptables redirect requests on port 80 to port 6680 and have a simple html page that redirects requests to musicbox_webclient. This is what PiMusicbox currently does.

If you want to keep the same hostname, you could have Avahi publish additional aliases for your system instead.

Rather than use iptables and a redirecting html page you could use a reverse proxy such as nginx. There are examples of that on here already if you search.

If I can’t use mopidy.local from Android, there’s little use in this. However, I was able to use volumio.local on Android with Volumio.

Actually, newer versions of Android might work, do you know what version you have?

Perhaps some clever routers can sort the mess out too. Not sure about that.

I have Android 6 and a Fritz box router.

I found this:

it is claimed that changing default dns address ( to “your own” (don’t know what it means) will do the job. Maybe router has it’s own dns address and is able to recognize localc domain ?

I’m assuming he’s referring to your own, as in your own local IP address. Your router usually handles immediate local DNS for anything connected to it, unless set otherwise, so its probably what he’s referring to.

Add your routers IP address ( or similar, can be found listed as Gateway in your Android Wifi settings) to your Android DNS BEFORE any Google or other DNS addresses (eg:

This XDA post has a bunch of different ways to change DNS on Android, choose whatever suits you:


That’ll basically tell your phone to ping your router for DNS requests first, if it doesn’t get an answer its happy with there it can move on to Google or whatever… but it should also open up local domain routing on your phone.

For the record, Zeroconf .local names are not supposed to work like this, so you are dependent on your router supporting zeroconf and helping you out here. Not all routers will.