Can connect to pi musicbox server through ssh and mopify, but says 'not connected'


#1

pi musicbox has been working perfectly for the past few days, but after updating mopify i can’t connect to any other web interface, and when on mopify it says it’s ‘not connected’, even though i can still connect through ssh fine and can get to musicbox.local/mopify/ normally. i’ve tried to upgrade mopify again, tried to update mopidy, and checked for updates, but nothing works (even after multiple reboots of the pi itself).

i got this error while trying to run mopidy in the console (idk if this means it’s an issue with mopidy or not, which is why i set the category as pi musicbox):

Traceback (most recent call last):
  File "/usr/local/bin/mopidy", line 7, in <module>
    from mopidy.__main__ import main
  File "/usr/local/lib/python2.7/dist-packages/mopidy/__main__.py", line 10, in <module>
    from mopidy import commands, config as config_lib, ext
  File "/usr/local/lib/python2.7/dist-packages/mopidy/commands.py", line 14, in <module>
    from mopidy.audio import Audio
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/__init__.py", line 4, in <module>
    from .actor import Audio
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/actor.py", line 10, in <module>
    from mopidy.audio import tags as tags_lib, utils
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/tags.py", line 10, in <module>
    from mopidy.internal.gi import GLib, Gst
  File "/usr/local/lib/python2.7/dist-packages/mopidy/internal/gi.py", line 9, in <module>
    gi.require_version('Gst', '1.0')
  File "/usr/lib/python2.7/dist-packages/gi/__init__.py", line 73, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Gst not available

the only tinkering around i’ve done in settings.ini after this is changing my hostname from 0.0.0.0 to :: as well:

[http]
hostname = ::
#Disable zeroconf
zeroconf = ""
static_dir = /opt/musicbox/webclient

will i have to do a fresh install of pi musicbox/mopidy?


#2

Yep, fresh install. Updating pimusicbox’s mopidy and extension versions is tricky and for that reason it’s just not supported.

For the record, it is documented in the faq but I don’t blame anyone for expecting it to work like normal!