Mopidy Discourse

Ubuntu -> Running Service -> Pulseaudio Bluetooth no Sound

Hi Community,

I need some assistance.

Mopidy runs as a Service on an Ubuntu machine.

I am looking to stream the mopidy sound over bluetooth to an hifi receiver.

Bluetooth speaker is connected and I get sound from Ubuntu on the speaker.

But mopidy isn’t able to play sound to the speaker.

Following configs i have made:

set etc/mopidy/mopidy.conf

[audio]
output = pulseaudio server:127.0.0.1

set etc/pulse/default.pa

load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1

In Ubuntu

set user mopidy to the bluetooth group

If I try to play tunein internet radio the stream breaks after 4 sec and there is no sound.

Has anyone an idea for my problem?

Regards

HansWerner

I ran into an issue getting sound using mopidy over bluetooth on a raspberry pi, but this link resolved it (which it seems you have already tried): Running as a service — Mopidy 3.1.1 documentation

From your description, the mopidy as a service does play sound over bluetooth for ~4 seconds. Does the tunein stream work for longer when playing using a audio jack? Does the sound also cut out when playing a local music file? Is the bluetooth speaker still connected after the tunein stream drops?

Hi bsaund

I had an test with a mp3 file. Unfortunately i don’t get sound either.

With the “iris” extension there is no sound output for selecting.

I am confused. It seems that Mopidy can’t get access to the sound server…