Trouble using MPaD 2.1 with Mopidy on Rpi3

I am new to all this, but trying to learn. I have Mopidy running on my Rpi3 and it seems to work fine with a local client (ncmpcpp). I have created a music library and I am able to play songs from that library to my Bluetooth speakers using this client and server. I have been trying to get an external client to access mopidy. I first tried Auremo and it requested that I remove the blacklist commands in the mopidy.conf file for [mpd]. That caused problems, so I discarded that and loaded MPad on my Ipad. I then explicity reset the blacklist commands in the mopidy.conf file. When I run mopidy config it now shows [mpd] command_blacklist (new line) listall (new line) listallinfo. When I run the debug log option on mopidy and use the ncmpcpp client; everything works and the log file looks fine. But when I try connecting from my Ipad using MPaD, it looks like mopidy is trying to send it all of my files on the Rpi3. MPaD just hangs “receiving data”

Anyone have any suggestion?


I think I solved my problem by limiting the search directories to only my Music directory. I also switched to MPod (because it is free) and run it on my IPaD. It now seems to find my Music and plays it ok. I returned most of the settings in the mopidy.conf file to default except for the local and file settings for Music directory.

I have the same problem with MPad.
I have not understood how you have resolved it: what do you mean exactly with “limiting the search directories to only my Music directory”?
Thank you very much.