Spotify Search don´t work


#21

Many thanks Nick, Spotify-search is working again.
First after applying the backport and setting the entries in settings.ini
manually, search didn’t work yesterday.
Today I had a look with the setting function in the web-client and put the
ratio-button for web-client acces to “ON”.
After that search is possible again. Great!!!
Is it essential to set it to ON, or was it fortune?


#22

This morning I was so happy that search in Spotify works again on my
MusicBox.
But now again search shows “No tracks found”.
Nick, any idea what I can look for.
Thanks in advance.


#23

Look for an error in your mopidy log file.


#24

Hi Nick,

here is an extrack from mopidy.log:

Can you have a look. Thanks.


#25

I would guess maybe certifi needs updating but I’m not sure. I’m pretty sure this doesn’t happen on the current musicbox release (correct me if I am wrong) and that’s the one I try and support. I don’t think I can help with this.


#26

Hi Nick,
I installed the release 0.7.0RC5. Isn’t that the newest one?
I wonder that I always get another client-id and secure-id when I connect
to the mopidy-auth-webpage with my spotify account. Is that ok?
Sorry for wasting your time.


#27

That is the newest one, I was under the impression from your previous post that you had manually updated a v0.6 image.

Yes, that is fine.

I just took the RC5 image, did exactly the steps in Post 8 and I don’t see this issue.

Can you login and run date, is it correct?


#28

Is it important to have the exact date and time set.
I know that it is not set correct, but I didn’t take care.
Is the Pi-MusicBox Installation looking for a timeserver and tries to get
the exact time from there?
Any way, I will set the exact time tomorrow and will give it another try.
I’ll come back with the result.


#29

Yes. SSL handshakes require this. Musicbox is designed to synchronise with a network time server during startup so normally it is correct. Sometimes it doesn’t work properly due to the network connection not being ready quickly enough.


#30

Hi Nick,
yes it is really essential that date and time is set to the right values.
If the timesetting is not correct search is not working.

Each time I’m rebboting my installation is loosing the timesetting.
What is the best way/configuration to get the right time after reboot?
(Sorry if I’m asking stupid questions, but I’m no so familare with Linux.)
I already installed the link for CET timezone.
Is it possible to have my Fritz-Box as timeserver?


#31

I found myself a working solution/workaround with ntpdate:

IP-adress from local Router/AVM-FritzBox is added as timeserver in
/etc/default/ntpdate

NTPDATE_USE_NTP_CONF is set to „no“, because IP-adress should be used
from this config file.

root@MusicBox:/etc/default# more ntpdate

The settings in this file are used by the program ntpdate-debian, but

not

by the upstream program ntpdate.

Set to “yes” to take the server list from /etc/ntp.conf, from package

ntp,

so you only have to keep it in one place.

NTPDATE_USE_NTP_CONF=no

List of NTP servers to use (Separate multiple servers with spaces.)

Not used if NTPDATE_USE_NTP_CONF is yes.

NTPSERVERS=“192.168.178.1 …”

Additional options to pass to ntpdate

NTPOPTIONS=""

Changes in /etc/rc.local

root@MusicBox:/etc# more rc.local

#!/bin/bash

rc.local

This script is executed at the end of each multiuser runlevel.

Make sure that the script will “exit 0” on success or any other

value on error.

In order to enable or disable this script just change the execution

bits.

Get current date and time with ntpdate from local router/AVM-Fritz-Box

(IP-adress is configured in /etc/default/ntpdate )


#32

Thanks, I just repair my musicbox with it !