Spotify Connect Error


#1

Hello all,

I’m having a problem with the Spotify Connect feature.
First, when Spotify Connect is active, on the MusicBox monitor the MusicBox login doesn’t appear.
Then, when I try to connect it with my phone over Spotify Connect it gives me this message:

thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: WireError("invalid value for enum: 13")', /checkout/src/libcore/result.rs:859
note: Run with `RUST_BACKTRACE=1` for a backtrace

Then the MusicBox disapears from the Spotify Connect List and the MusicBox Login appears on the monitor and I can log myself in.

Is there a solution for my problem?


#2

Exact same thing happening here on my (Raspberry Pi based) box.

Haven’t found a solution yet…


#3

Hi All,

I have been using Spotify Premium on my Pi Musicbox a few months now, worked as a charm really enjoying it. But since a few weeks Spotify rejects the Musicbox. After a reboot the Musicbox appears on the Spotfy device list, when trying to connect to it the musicbox is removed from the device list. A friend of mine who has the same build experiences the same problems. I also have a Bose Soundtouch no problems there.
Is this a known issue, has Spotify changed their platform?

regards,
J


#4

It’s a known issue due to Spotify changing something. It has been fixed upstream in librespot so it just needs recompiling. I’ve got a new musicbox release (with support for the new raspberry pi) which includes this fix. I’ve been testing this weekend and assuming nothing pops up I aim to release it tonight/tomorrow.


#5

Hi Kingosticks
Great news, thanks!
cheers, J


#6

Great to hear, thanks! So I assume the new release will be uploaded to https://github.com/pimusicbox/pimusicbox/releases eventually (as 0.7.0 RC6 or something)?


#7

Yes: https://github.com/pimusicbox/pimusicbox/releases/tag/v0.7.0RC6


#8

Hi all,

I just installed this release to my pi but can’t find the music box in spotify, although spotify connect is enabled.
Playing songs from spotify through the web interface works fine though.

Any suggestions on how to troubleshoot this?


#9

Hey everybody,

i got an similar problem. None of the Spotify integration works on my setup. I can’t even play a song. I already checkt every log, but nothing of particular interest. In Mopidy my account shows up as connected, but nothing else works.

Maybe somebody got an idea.

Greetings,
Moki


#10

@jubobey Spotify connect (librespot) requires an update and this must be done manually. You need to enable ssh and then login so you can run the following commands.

service librespot stop
cd /opt/librespot
wget https://github.com/pimusicbox/librespot/releases/download/v20180529-1e69138/librespot-linux-armhf-raspberry_pi.zip
unzip librespot-linux-armhf-raspberry_pi.zip
rm librespot-linux-armhf-raspberry_pi.zip
service librespot start

Or wait for the next release.


#11

@Mokizozl

If you cannot play a spotify song through the Web interface then this is not the same issue. Please start a new thread and provide the Mopidy log file. Thanks.


#12

Solved my problem, thanks!


#13

hi Kingosticks,

Busy reinstalling mij pi musicbox
Trying to update librespot getting following error, something with a certificate, trying to download the zipfile.
What is wrong?

Thx, jw

root@MusicBox:/opt/librespot# wget https://github.com/pimusicbox/librespot/releases/download/v20180529-1e69138/librespot-linux-armhf-raspberry_pi.zip
–2018-03-15 23:51:50-- https://github.com/pimusicbox/librespot/releases/download/v20180529-1e69138/librespot-linux-armhf-raspberry_pi.zip
Resolving github.com (github.com)… 140.82.118.3, 140.82.118.4
Connecting to github.com (github.com)|140.82.118.3|:443… connected.
ERROR: The certificate of `github.com’ is not trusted.
The certificate has not yet been activated


#14

I’ve never seen that before. I suggest you have a Google around.


#15

This worked like a charm!
Thanks for posting :slight_smile:


#16

Got it working, probably a clitch, thx!


#17

Hello,
was working fine. I had to re-install mopidy today, but on download I got this error:

ERROR: The certificate of `github-production-release-asset-2e65be.s3.amazonaws.com’ is not trusted.
The certificate has expired.

Any idea how to fix this ?

Thanks !


#18

Working:

wget --no-check-certificate https://github.com/pimusicbox/librespot/releases/download/v20180529-1e69138/librespot-linux-armhf-raspberry_pi.zip


#19

#20

Closed this thread as it now contains three different issues over the span of 7 months.