Some tunein radio stations not supported


I’m new to Pi Musicbox and have trouble to play some tunein radio stations. My favorite station is “kiss fm 106.1”. The search result gives me:
Kiss 106.1 FM - Not Supported
No compatible stream / Kiss 106.1 FM - Not Supported
I have found an m3u file with the stream URL on ( I can play this URL with my music box (via Streams).

What could be the problem with the tunein search result?

Thanks for your help.

I think Musicbox v0.6 contains an older buggy version of Mopidy-TuneIn. Or it could be that the link in TuneIn’s catalogue is dead. I tried to find that station with the latest version but I got a lot of search results (which all worked) so I’m not sure I was trying the right station. If you are feeling brave you can try to update your Musicbox installation with these (unofficial) instructions or wait for the new Musicbox version (I’d recommend the latter).


I made a backup of my sd card and tried the upgrade, but the command:
pip install -U -r ~/pip-packages.txt
ended with:

creating build/temp.linux-armv6l-2.7
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -I/usr/include/python2.7 -c alsaaudio.c -o build/temp.linux-armv6l-2.7/alsaaudio.o
alsaaudio.c:23:28: fatal error: alsa/asoundlib.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1
Rolling back uninstall of pyalsaaudio
Command "/usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip-build-4aRysr/pyalsaaudio/';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-gbF8ha-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-4aRysr/pyalsaaudio

So because you found too many search results, please search on tunein for “dubai92”. There is only one search result. This station has the same “not supported” problem. Maybe this helps to reproduce the problem.