Smb connection error 112 host is down


#21

root@MusicBox:/# mount -t cifs -o ro,vers=1.0,ip=192.168.1.1 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

mount: fstab path: “/etc/fstab”

mount: mtab path: “/etc/mtab”

mount: lock path: “/etc/mtab~”

mount: temp path: “/etc/mtab.tmp”

mount: UID: 0

mount: eUID: 0

mount: spec: “//SynologyRouter/usbshare1/mediafolder/music”

mount: node: “/music/Network”

mount: types: “cifs”

mount: opts: “ro,vers=1.0,ip=192.168.1.1”

mount: external mount: argv[0] = “/sbin/mount.cifs”

mount: external mount: argv[1] = “//SynologyRouter/usbshare1/mediafolder/music”

mount: external mount: argv[2] = “/music/Network”

mount: external mount: argv[3] = “-v”

mount: external mount: argv[4] = “-o”

mount: external mount: argv[5] = “ro,vers=1.0,ip=192.168.1.1”

ip address 192.168.1.1 override specified

Password:

mount.cifs kernel mount options: ip=192.168.1.1,unc=\SynologyRouter\usbshare1,vers=1.0,user=root,prefixpath=mediafolder/music,pass=********

mount error(13): Permission denied

Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

root@MusicBox:/#

got Permission Denied, so as a bit of poke-and-hope I tried supplying my admin userid and password in the mount command

root@MusicBox:/# mount -t cifs -o ro,vers=1.0,user=admin,password=#######,ip=192.168.1.1 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

mount: fstab path: “/etc/fstab”

mount: mtab path: “/etc/mtab”

mount: lock path: “/etc/mtab~”

mount: temp path: “/etc/mtab.tmp”

mount: UID: 0

mount: eUID: 0

mount: spec: “//SynologyRouter/usbshare1/mediafolder/music”

mount: node: “/music/Network”

mount: types: “cifs”

mount: opts: “ro,vers=1.0,user=admin,password=arathi123,ip=192.168.1.1”

mount: external mount: argv[0] = “/sbin/mount.cifs”

mount: external mount: argv[1] = “//SynologyRouter/usbshare1/mediafolder/music”

mount: external mount: argv[2] = “/music/Network”

mount: external mount: argv[3] = “-v”

mount: external mount: argv[4] = “-o”

mount: external mount: argv[5] = “ro,vers=1.0,user=admin,password=#######,ip=192.168.1.1”

ip address 192.168.1.1 override specified

mount.cifs kernel mount options: ip=192.168.1.1,unc=\SynologyRouter\usbshare1,vers=1.0,user=admin,prefixpath=mediafolder/music,pass=********

root@MusicBox:/#


#22

Whazaaaaaa! the musicbox is scanning the network files now. Do I need to add that mount command to fstab or something now so this mounts after any necessary reboots?


#23

That’s great. You should be able to use the existing settings.ini with everything filled in like normal and:

mount_options = vers=1.0,ip=192.168.1.1

#24

I also needed this patch and config (from Kingosticks first post) to get Musicbox to connect to my Fritzbox 7390 router. I also got the error 112 before.

Vers=1.0 did the job.

Just if anybody else runs in this problem.

Thank you for your great software and support!


#25

I hate to bring this old thread back up… but I cannot get the musicbox to automatically mount on boot. I have to connect through putty and run “mount -t cifs -o ro,vers=1.0,user=admin,password=#######,ip=192.168.1.1 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv” every time I need to restart the pi.

I have updated to the most recent version of Pi Musicbox, gone through the thread and applied the startup.sh update, added the mount options and followed any other instructions. I have also tried adding the mount command as a line in fstab… but nothing seems to work. Any advice?

Thank you

Tim


#26

I just installed Pi MusicBox 0.7rc6 for the first time and had this issue. The fix from kingofsticks worked for me.

Thanks!