Seems to be working but there's no audio from jack

Noob here. I just installed the software and it seems to be running. It’s pulling playlists from LastFM and seems to be playing, yet there’s no audio coming out of the jack on the Pi.

Any basic trouble shooting ideas??


Have you got a hdmi cable connected and left the audio setting undefined?
If so, it’ll default to using hdmi.

There’s no HDMI cable attached - only the analog audio jack. This is a board that a friend has lent me - I’m not even sure the audio jack works.

Is there anything else that would prevent the audio from playing?

If you had a USB soundcard (and left the audio setting undefined ) it would try to use that, but sounds like we can rule that out. Is it a model B+ Raspberry Pi? If so, you might have the wrong type of connector on your audio cable - see

I can’t think of anything else that might be a problem. You could try running the following command to test your audio:
aplay /usr/share/sounds/alsa/Front_Center.wav

Hi King,
I ordered the little USB sound card in the how-to article for better audio. That might be the work around.

With regard to the jack - I hadn’t realized it wasn’t just a simple audio jack. I tried plugging Apple headphones into it and didn’t hear anything. The PC speaker I’d had attached probably wouldn’t work as they have a 3 conductor plug?

I’ve yet to run into the cable issue myself but we have had others fall
victim. But do note that it only applies to the newer models.

Problem resolved. The little USB sound card solved the problem and works perfectly!