Mopidy Discourse

Rpiz2 Pypi Install not creating mopidy user?

Hello, any help would be greatly appreciated.

I am trying to install Mopidy from pypi, on a rpiz2:
Uname: Linux 5.10.63-v7+ #1488 SMP Thu Nov 18 16:14:44 GMT 2021 armv7l GNU/Linux

After install, there does not seem to be a mopidy user nor is there mopidyctl. mopidy is there and seems to start, but I usually run mopidy as service.

I started with a new sd lite, installed all dep as stated in docs. At this point I have uninstalled/installed a few times so perhaps need to nuke and pave.

Note: in the past I usually install mopidy from APT the first time then use pip to keep it and the extensions updated, but wanted to just use pip from the start this time.

https://docs.mopidy.com/en/latest/installation/pypi/#general

$ sudo python3 -m pip install --upgrade  mopidy
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting mopidy
  Using cached https://www.piwheels.org/simple/mopidy/Mopidy-3.2.0-py3-none-any.whl (127 kB)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from mopidy) (52.0.0)
Requirement already satisfied: tornado>=4.4 in /usr/local/lib/python3.9/dist-packages (from mopidy) (6.1)
Requirement already satisfied: Pykka>=2.0.1 in /usr/local/lib/python3.9/dist-packages (from mopidy) (3.0.2)
Requirement already satisfied: requests>=2.0 in /usr/lib/python3/dist-packages (from mopidy) (2.25.1)
Installing collected packages: mopidy
Successfully installed mopidy-3.2.0
 ~ $ which mopidy
/usr/local/bin/mopidy
~ $ which mopidyctl
~ $ 
<no mopidy user in passwd>

(ps: is there a way to get a preview before posting topic here?)

You must install the Debian package to have the service setup on your system. Pypi is just Python source. apt.mopidy.com should have the same versions that are available on Pypi. You should use Debian packages where you can and pypi where you cannot (web clients etc).

Thank you I thought that may be the problem.

I thought apt.mopidy.com is only buster and I am using bullseye. Will that matter?

Should I nuke and pave (create a fresh SD and install) or just install on the current pypi adulterated SD?

Thanks again!

It does not matter.

Debian 10 (Buster), which also works for Raspbian Buster and Ubuntu 19.10 and newer.

Starting over night be less confusing as you’ll be following the suggested route but installing over the top should work OK if you’ve not messed with things.

Perfect!

I Uninstalled mopidy and extensions using pip.
Then installed Mopidy on bullseye using apt.mopidy.com/buster.list and it all seems to be going good.

Thanks again…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.