Problem with local music


i dont know where to put my local music on the musicbox. I tried /music/MusicBox/ and /home/mopidy/music. I’ve set always_scan to true so it should have found the music. But going to Browse - Local media it just says Loading data from MusicBox… Am I doing something wrong?

thanks in advance,

edit: in settings.ini local directory is set to /music and enabled so it should find the music there… My Music is sorted into directories ARTIST/ALBUM/TITLE.mp3 is this the problem?

edit2: just did an upgrade with “apt-get upgrade”, musicbox responds faster now, still getting stuck with “Loading data from MusicBox” when trying to browse local media…

We still haven’t quite fixed mopidy to reload scanned data while running. So a restart is still required. Not sure how this has been solved in pimusicbox though.

As for how things are sorted, we normally just do a search and don’t really care about what directory structure you use.

If you could provide some logs we could probably have a better chance of figuring out what is happening. But not sure where pimusicbox puts it’s logs, on a regular mopidy install /var/log/mopidy would be where to look.

Restarting does not seem to fix it. Tried it several times, with scan on startup and without… Even tried switching to json, it didnt help.

The logs are in this directory. In modpidy.log there is only one error, naming that mopidy couldnt find the json file (this was just after i switched to json). There is also an modpidy.log.1, but it just has logged files from before i put it on the pi.

I think it doesn’t find the music. Because opening the library.json.gz.1awPmH inside library.json.gz shows this:

  "tracks": [],
  "version": "0.18.3"

any suggestions?


switching back to the default setting: whoosh somehow got things working for me or maybe it was the mp3 file i put in /music who knows…

So it works now? How did you put them on the card? Maybe it’s a permissions issue?

yeah, i first put the music on the card using a linux distribution. I checked the rights when they were not detected and found out the rights were rwx------ so that could’ve been the problem. I pushed the single mp3 via scp to the musicbox. I then changed permissions of two artists to rwxrw-rw-. Then all music was found. If the permissions were the problem, why are even those mp3s found whose permissions i didnt change?

On MusicBox it works when using Samba/Windows Networking indeed. When copying directly in Linux, permissions and user/group must be set.
You can fix it issuing these commands I think:
chmod -R u+rwX,go+rX,go-w /music
chmod -R ugo-x,u+rwX,go+rX,go-w /music

My initial scan of local files resulted in many issues such as splitting of albums which I found to be caused by incorrect tags. I’ve corrected several of these tags using Foobar (in Windows) but rescanning does not seem to resolve the issues in Album Browse.
Does the scan look for new files or replace the whole database? If the former, is there any way to delete the database to refresh edited tags on rescan?