Port 22 no longer the ssh listening port


#1

Hi,
I am new to the world of PI and linux and thus require the support of anyone with knowledge to help me out of a trouble spot Î’m in. In my initial set-up of musicbox, while in “raspi-config”, I was doing a file system expansion when the PI crashed. Upon rebooting and trying to ssh back onto the PI, I discovered that in the process something changed the configuration of the listening port for ssh and that port 22 is no longer the ssh access port.

I have tried pretty much everything I could think of and then some but to no avail. My second to last possible solution was to simply re-write the image file onto the SD disk but to ky surprise, it seemed the new config (post crash) was kept even with the use of the new image file.

So my last option and hopefully the right one, is to turn to you folks and hope someone has a better idea than my daugther, which for the record was, to order a new PI…

Sincerely,
Robert


#2

I had another report very recently that the filesystem was not being expanded automatically on first boot as it should be. There should be no need to use raspi-config as doing so may mess up the settings pimusicbox has already tried to configure. I’ve not had a chance to look into that yet but it’s strange since that code hasn’t changed.

Is there a reason that you think the SSH port has changed? Is it possible that SSH is just not running (the default on Pi Musicbox and also on Raspbian for some time now)?

If you rewrite the SD card you cannot possibly be using anything but a fresh config at which point SSH is disabled until you explicitly enable it in settings.ini/websettings.


#3

Kingosticks,
Just to relate the history of the said issue: port 22 was indeed the initial listening port has it was displayed in my terminal window upon my first ssh connection. Now when I try to ssh, the message I get is: musicbox_ip port: 22 connecion refused.
I agree and obviously thought that re-writting the SD card would solve my issue, but it seems not. Is there a way where I can force the use of a specific port before I insert the SD card in the PI. Once inserted, it’s too late if the ssh listening port is other than 22, Î’ll never be able to ssh onto the PI?

Let me knw if it makes sense and keep n mind the fact that I am just about as novice one can be in this feld!
Sncerely,
Robert


#4

OK, so that error is telling you that SSH is simply not running.

If you want to have SSH running you need to set:

enable_ssh = true

in your settings.ini OR via the websettings.


#5

Kingosticks,
I was about to say that I of course did turn the ssh access on withn the websettings, but checking back, it seems it was not the case. Therefore, please accept my sincere apologies for the trouble and will try to be more careful the next time around.
Sincerely,
Robert


#6

No worries, Robert. This has reminded me to look into that possible filesystem resizing issue, so thank you!