Play udp radio stream

Is there a possibility to play udp stream? There is just an IP and port. Playlist file looks like:
Title1=Radio Title
Tested the playlist with other software, and it’s working. Also tried the udp address withouth @, no luck. Codec used is MPEG Audio layer 1/2/3 (mpga).

I have lot of these through my ISP, so it would be great to get it working.
Any hints?

See for details, but all that should be missing is adding config section to your musicbox/mopidy config:

protocols = file,http,https,mms,rtmp,rtmps,rtsp,udp

The format of the udp url and the codecs should both be supported.

you can add that to the settings.ini file directly. I will add it by default too. thx

@woutervanwijk Would you mind also adding mmsh to musicbox defaults while you are there?

We should probably just fix the defaults in mopidy as well.

Ok, I added mmsh as well!

I was not successful playing the udp stream, after done changes in settings.ini (also mopidy.conf). I tried Auremo client and Musicbox prerelase web client. From mopidy.log I just get:
WARNING Problem looking up udp://XXX.X.X.XXX:XXXX: Timeout after 5000ms
How could I investigate further?

Try adding metadata_blacklist = udp://* to the stream settings. Thing that fails is looking up metadata for the stream, and this disables it. If it still doesn’t work then something more fundamental is wrong.

Added, but still doesn’t work. Now I don’t see anything in log either.
If I play this stream through http, it works. But this means going through my video disk recorder (VDR streamdev plugin) which turns it into http stream. I would really like to bypass it.
Anything else I could investigate?

Could you share the stream you’re trying to use with us?

OK, @adamcik has just kindly pointed out to me on IRC that you’ve already said the stream is from your ISP so it won’t work for us anyway.

Could you try running the following with your stream GST_DEBUG=3 gst-launch-0.10 playbin2 uri=udp://XXX.X.X.XXX:XXXX

pasted it here
Hope it helps.

Theres a few different warnings in there. The jack stuff I think we can safely ignore.

It complains a lot about “unsupported query format or no bitrate yet to approximate duration from bytes” and searching for that doesn’t bring up much except which suggests it’s broken in 0.10. I don’t know how to force the usage of tsdemux over mpegtsdemux. Maybe you could try and create a gst-launch-0.10 pipeline using it specifically rather than letting playbin2 figure it out? Or perhaos you can try setting the pipeline caps yourself so mpegtsdemux doesn’t have to do a query?

But that could all be a red herring. I’m really just guessing. Any ideas @adamcik ?