Flac radio playback possible?

Simple question perhaps: but is it so that mopidy/pimusicbox cannot play flac-based online radiostreams at all?

I can only confirm that Mopidy can play both local files in FLAC format and FLAC streamed via Mopidy-InternetArchive.
Do you have an example of a FLAC radio stream, so we can check what’s going on here?


Tried both using the address directly and from within a playlist file. Didn’t play.

I also can’t play the first stream, in the logs I repeatedly get:

WARNING  2015-03-27 15:53:39,319 [11319:StreamBackend-3] mopidy.stream.actor
  Problem looking up http://radio.cesnet.cz:8000/cro-d-dur.flac: Timeout after 5000ms

So probably not a Mopidy but a server or network issue.

The second, after some initial delay (buffering, I guess), plays just fine.

Disclaimer: I’m running Mopidy v1.0 :wink:

Note also that I tried this out on my Laptop and a 75Mbps Internet connection (according to speedtest.net).

Although I haven’t experienced major problems streaming FLAC on the Raspberry Pi, with it’s limited processing power and USB-based Ethernet/WiFi, this could also make a difference.

Also tried with gst-launch-0.10 -vt playbin2 uri=... and they both seem to work, they are just really really slow to get started. Greatly increasing https://docs.mopidy.com/en/latest/ext/stream/#confval-stream/timeout or adding the sites to https://docs.mopidy.com/en/latest/ext/stream/#confval-stream/timeout should help.

Ok. I’ll try this then.

What kind of figures are we meaning with “greatly increasing”. More than 25%?

I have this principle that I stay away from companies that spam. Sorry.

Sorry but Frequency 3 is not a companie, it is a non-profit community radio
it seemed interesting to me to give you a link for a FLAC broadcasting, it’s rather uncommon … right?

30s, maybe a minute, so 30000-60000 or so. But if you blacklist the URIs you should be good without changing this, you just won’t get any info about what is playing.

I tried both of the solutions you offered, unfortunately they didn’t work. What I notice from the router is that data is being downloaded, and from “top” i notice that mopidy is using 30% cpu. This seems to indicate that something is happening. However, no sound is produced. There are no error (related to this) in mopidy.log

I wonder what these mean?

FOUND TAG      : found by element "flacparse0".
         bitrate: 669615
/GstPlayBin2:playbin20/GstInputSelector:inputselector0.GstSelectorPad:sink0: tags = ((GstTagList*) 0x15170a8)
FOUND TAG      : found by element "flacparse0".
         bitrate: 659558
/GstPlayBin2:playbin20/GstInputSelector:inputselector0.GstSelectorPad:sink0: tags = ((GstTagList*) 0x14f8a48)
FOUND TAG      : found by element "flacparse0".
 minimum bitrate: 408666

I have now found more flac streams and I have noticed that some always work, while others do not ever work. I don’t know what the reason for this is. I have noticed that the ones that work seem to all be 44.1 kHz and the 48 kHz ones seem to not work… is this possible some how?

I have installed Musicbox based on Mopidy on my Raspberry Pi. Everything works fine except streaming of high-res radio-stations.
For example I tried to listen to http://sr7.inmystream.info:9100/stream.flac which is 44.1kHz, 16Bit, flac.
But the request ends in a timeout:
2016-02-17 16:15:45,852 - WARNING Problem looking up http://sr7.inmystream.info:9100/stream.flac: Timeout after 20000ms
As you may see, I have increased the timeout to 20s, but it doesn’t help.
With VLC it works fine.

Any hints are welcome!

Please create a new topic for your question rather than hijacking this very old one. In your new post make sure you include what version of Mopidy you are using, you can find this by running mopidy deps.

I just want to report that whatever was causing this problem is not present in the latest mopidy. I forgot about this until today I tried and copy-pasted the addresses from this thread to the “streams” section in musicbox-webclient, and all of them work.