Ogg streams not working

As per subject line. While mp3 audio streams work, ogg streams don’t.

This is the stream I tried:


This is all I find in the log file:

2015-10-04 14:52:18,425 INFO [1028:StreamBackend-9] urllib3.connectionpool: Starting new HTTP connection (1): dradio-ogg-dlf-l.akacast.akamaistream.net

Meanwhile CPU usage shoots up, and any attempt to play another file or stream or podcast after trying to play the ogg stream also fails until I restart mopidy.

The stream itself plays fine with gst-launch playbin uri=http://dradio-ogg-dlf-l.akacast.akamaistream.net/7/629/135496/v1/gnl.akacast.akamaistream.net/dradio_ogg_dlf_l so it’s no a gstreamer issue

Unfortunately, this is one of a number of bugs making mopidy just unusable for me at the moment (webclient fails on playlists, tunein radio stations also not working because of an issue with nested playlists). A couple of months back, it worked nearly perfect, now I can barely do anything with, basically only podcasts

Replying to myself: I have now downgraded to mopidy 1.0.8, which fixes all these things. Somehow the 1.1 release really has screwed things up for me.