No output card found (raspberry pi zero + phat DAC + Pi MusicBox)


I’ve just soldered a phat dac ( on my pi zero and wish to get some audio output from Pi Music Box but after updating some settings I know get

Fail, no output card found.

I followed the instructions here

So my files look like this:
#######blacklist spi-bcm2708
#######blacklist i2c-bcm2708


pcm.!default {
type hw card 0
ctl.!default {
type hw card 0


output = hifiberry_dacplus

Any help would be greatly appreciated! Thanks

I would have said, undo everything you changed following that guide and simply set output = hifiberry_dac in /boot/config/settings.ini. Did you try that before making all those changes?

Nope didn’t try that, will give it a go, thanks for the suggestion!

Ok that gets rid of the error, I can now browse to musicbox.local but still no sound being outputted, any further ideas?

The output from aplay-l returns ALSA [bcm2835 ALSA]

Aha getting closer got to a stage where it now shows

card1: sndrpihifiberry

as part of the aplay -l output

but still no sound going out

Take a look in in your system logs for any problems during startup. Probably worth double checking there are some sensible volumes in alsamixer. Failing that, please post the full output of

  • aplay -l
  • cat /etc/asound.conf

it’s working now, thanks for the help! (did a fresh install and just changed the setting you suggested).

Great news, glad to hear it. And thank you for updating this thread.

Hi, I have the same problem that TimGeyssens had. I have followed the guide and this post but to no avail. aplay -l output gives something very similar to card1: sndrpihifiberry and cat /etc/asound.conf gives;
pcm.!default {
type hw card 0
ctl.!default {
type hw card 0
But no sound at all when I test the DAC. I also do not have any config file regarding/boot/config/settings.ini in boot directory. I am using the latest version of Raspbian as well.
I would appreciate any help.
Thank you.

This thread is regarding pimusicbox, not latest raspbian.

This thread is also very old and the latest raspbian is not configured like this anymore.

Since your hifiberry is on card 1, I presume you have the onboard audio assigned to card 0. And your asound.conf file is set to use card 0. So either change that file to specify card 1 or disable the onboard sound (see the official raspberry pi documentation on how to do this properly on latest Raspbian).

If you are still having problems then please start your own topic in the normal (not pimusicbox) part of this forum and specify the full contents of ‘aplay -l’.