No Analog Audio when HDMI is connected


#1

I’m using a RPi and running mopidy locally (not as a service). I’ve got an HDMI cable connected for video output, but I’ve selected analog as the main output for my pi and have confirmed that I can hear audio fine on a youtube video, just not when playing music through mopidy.

Here’s my config file:

[core]
#cache_dir = $XDG_CACHE_DIR/mopidy
#config_dir = $XDG_CONFIG_DIR/mopidy
#data_dir = $XDG_DATA_DIR/mopidy
#max_tracklist_length = 10000
#restore_state = false

[audio]
mixer = software
mixer_volume = 100
output = autoaudiosink
#buffer_time = 

[softwaremixer]
#enabled = true

[spotify]
enabled = true
username = xxxx
password = xxxx
client_id = xxx
client_secret = xxx

#2

And what about https://docs.mopidy.com/en/latest/installation/raspberrypi/#testing-sound-output ?

Any errors in the log?


#3

Yes, that works fine. I hear ‘Front Center’

Here’s my log when I fire up Mopidy:

INFO     Starting Mopidy 2.1.0
INFO     Loading config from builtin defaults
INFO     Loading config from /home/pi/.config/mopidy/mopidy.conf
INFO     Loading config from command line options
INFO     Enabled extensions: spotify, mpd, http, moped, stream, m3u, softwaremixer, file, api_explorer, local
INFO     Disabled extensions: none
INFO     Starting Mopidy mixer: SoftwareMixer
INFO     Mixer volume set to 100
INFO     Starting Mopidy audio
INFO     Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend, SpotifyBackend
INFO     Audio output set to "autoaudiosink"
INFO     No local library metadata cache found at /home/pi/.local/share/mopidy/local/library.json.gz. Please run `mopidy local scan` to index your local music library. If you do not have a local music collection, you can disable the local backend to hide this message.
INFO     Loaded 0 local tracks using json
INFO     Starting Mopidy core
INFO     Logged in to Spotify in offline mode
INFO     Logged in to Spotify in online mode
INFO     Starting Mopidy frontends: MpdFrontend, HttpFrontend
INFO     MPD server running at [::ffff:127.0.0.1]:6600
INFO     Starting GLib mainloop
INFO     HTTP server running at [::ffff:127.0.0.1]:6680

#4

Did you actually try and play a track during that log?


#5

Yes. I’m using Moped, which loads just fine and populates my spotify account info as expected. In fact, it shows the track progress bar as expected as well. just no sound.


#6

Hey, I’m new to this but I had the same problem and found that installing gstreamer1.0-pulseaudio got me one step closer.

sudo apt-get install gstreamer1.0-pulseaudio

hope this helps


#7

Turns out I switch the audio to Alsa and it worked fine…


#8

I don’t understand, in your first post you said you had already done that.

Edit:
Apologies, no you didn’t, my mistake. But I’m still a bit confused, doesn’t the pi always use alsa? Is this stretch or jessie?