Mopidy Discourse

Mopidy on Raspberry 3: no audio

Hi Everyone,
I am trying to setup Mopidy on a fresh install of Raspbian 10.6 (buster)
I followed the instructions as in https://docs.mopidy.com/en/latest/installation/raspberrypi/#how-to-for-raspbian
I am running it in terminal, but there is no audio.
My mopidy.conf (just the non-commented rows):

[audio]
output = alsasink

[http]
hostname = 0.0.0.0
port = 6680

If I run mopidy it shows no errors, I can access it from a browser and make it play something (I installed Mopidy-TuneIn from pip and I can access web radios. But I still don’t get any output from the jack.

Ii I run “aplay /usr/share/sounds/alsa/Front_Center.wav” I can hear it correctly

Anyone can help me?

Are you using the desktop version of Raspbian? Do you have a HDMI monitor connected? Did you select the audio jack as the default (sudo raspi-config -> Advanced Options -> Audio) ?

It might be helpful to provide the output of running Mopidy in your terminal.

Adding the verbose flag to aplay should let us see what PCM device it considers the default:

aplay -v /usr/share/sounds/alsa/Front_Center.wav

And then aplay -L lists all the available PCM devices, one of which will be the default. Then use aplay -l to show the available soundcard devices. Hopefully we can then see which soundcard device we need to tell alsasink to use e.g.:

gst-launch-1.0 -v audiotestsrc ! audioresample ! alsasink device=hw:0,0

I think you can even tell alsasink to use a particular PCM device e.g:

gst-launch-1.0 -v audiotestsrc ! audioresample ! alsasink device=sysdefault:CARD=Headphones