New user: is this right and what now?

Last login: Sun Oct 11 13:28:39 on ttys000
server:~ HQ$ mopidy
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
INFO Starting Mopidy 1.1.1
INFO Loading config from builtin defaults
INFO Loading config from /Users/HQ/.config/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: mpd, http, stream, m3u, softwaremixer, file
INFO Disabled extensions: local
WARNING Found local configuration errors, the extension has been automatically disabled:
WARNING local/media_dir must be set.
WARNING Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO Starting Mopidy mixer: SoftwareMixer
INFO Starting Mopidy audio
INFO Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend
INFO Loaded 0 M3U playlists from /Users/HQ/.local/share/mopidy/m3u
INFO Audio output set to "autoaudiosink"
INFO Starting Mopidy core
INFO Starting Mopidy frontends: MpdFrontend, HttpFrontend
INFO MPD server running at [::ffff:]:6600
INFO HTTP server running at [::ffff:]:6680

it doesnt seem to appear on bonjour
manual setup from mpad doesnt wrk.
it took me ages to realise that command not found would be solved by a reboot.
I never set any config as the web page says only thre elines and the actual file has many, all commented out I think this being because they are all defaults

My music is on my nas, how/where do I tell mopidy about it? All I can see are local refernces.

Just don’t know what I am looking at. Not used command line since dos.


I believe you require avahi-daemon to be installed for this. Do you?

Not totally sure what you mean here but I imagine you just needed to start a new shell rather than reboot.

Yes, you only need to set config where it differs from the default as per the docs

mopidy-local is indeed for local file so you could mount your network drive and use that. Or, if your NAS supports DLNA, you could use the wonderful Mopidy-dLeyna instead.

First let me say a grateful thank you for your reply and so quickly.

I have previously read through the docs you linked, but have to admit they mean very little to me. I think it’s the lack of context perhaps. If I just needed syntax they are great, but It’s rather like having instructions for a route across London when I don’t know which country I am in.

In the docs it says a basic config file needs only three lines; though I seem to think the two about spotify are for something that is an extension I have not yet added.

Then later the docs lists a config file with many items set =

Whereas my config file has many lines all commented out (which could be great as a guide) .
As I understand it I must install so that I can

connect to my Synlogy NAS music store (I can’t find the syntax or the location to enter it)
allow MPaD clients to connect, specifically MPaD as I use that to connect to my bryson.
add an “extension” for spotify

The idea being to play music from both my NAS and Spotify seemlessly.

However, I seem to be sinking into a terminal process. (that’s a joke)

Yes I guess new shell would have solved instead of reboot - I’d forgotten what a “shell” really is.

I’ll have a google/link click (thanks) and see what I can discover about these.
I am a bit dismayed right now as I just wanted to play my music and wonder if this is not all a bit beyond me - I was command lining in the eighties… memory and skills fade.

I don’t know if the daemon you mention is running, it will not be if it’s something I have to install or run as I have not - I just followed the instructions.

I am grateful for your help, thanks


edit I ran this

pip install Mopidy-dLeyna

and seems to be installed. Don’t know how to run it.

I think you have some typos in the middle section of your previous post as it doesn’t make complete sense (who/what is ‘bryson’?).

You can run sudo service avahi-daemon status to see if the avahi-daemon is running. This is a background process which mopidy needs to communicate with in order to advertise itself using zeroconf/bonjour.

You can probably use some of the information at to configure your Synlogy NAS. If you run mopidy deps it’ll print all the extensions that you have available. if you look at Mopidy’s log output during startup it will also print out which extensions are enabled. For Mopidy-dLeyna there shouldn’t be anything to configure so it should be enabled. Then you would need to goto the Browser section of your client and there should be a " Digital Media Servers" entry and hopefully under that you will find your NAS. I’ve never used your client so I can’t be any more specific that that.

Hi yes Bryson should have been Bryston

It sounds like you are saying I could run mopidy on my Synology NAS drive instead of having to use the OS X Mac Mini I have attempted to install?

Wondering if I should do that though if I do then I need a means to get a signal from Ethernet into my dac, which being active PMC speakers require AES3/EBU digital input, ie the network streamer I am trying to replace with the Mac…

Going round in circles here.

Open to suggestions. Though I’ll try again with mopidy following your suggestions and see if it works. Would certainly be great from what I have read about it.

Thanks again


No, I’m not saying that. Music lives on the NAS. Configure the NAS as a
DLNA server as per the synology documentation I linked to. Mopidy (running
on some other system) is then able to access your music on the NAS via