Mopidy-Spotify with ncmpcpp not working


#1

Hi! I’ve just installed arch couple of days ago and i’ve been trying to use ncmpcpp with my spotify account.
But i couldn’t make it works. Anybody can help me?

Here i paste .conf files:

mopidy.conf

[spotify]
enabled = true
username = ****
password = ****
client_id = ****
client_secret = ****

mopidy.service

[Unit]
Description=Mopidy music server
After=avahi-daemon.service
After=dbus.service
After=network.target
After=nss-lookup.target
After=pulseaudio.service
After=remote-fs.target
After=sound.target

[Service]
User=mopidy
ExecStart=/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf
Type=simple

[Install]
WantedBy=multi-user.target

systemctl --user status mopidy

mopidy.service - Mopidy music server
Loaded: loaded (/home/ale/.config/systemd/user/mop>
Active: failed (Result: exit-code) since Mon 2019->
Process: 12129 ExecStart=/usr/bin/mopidy --config />
Main PID: 12129 (code=exited, status=216/GROUP)

Also when I input mopidy in console it throws these warnings

WARNING  Found local configuration errors, the extension has been automatically 
WARNING    local/media_dir must be set.
WARNING  Please fix the extension configuration errors or disable the extensions to 
silence these messages.
ERROR    Frontend (MpdFrontend) initialization error: MPD server startup failed: 
[Errno 98] Address already in use

It’s this error a problem of my ports? how can i solve it?


#2

Are you concerned about the warnings or the error? The error is because some other process is already using the mpd port that’s configured. Two processes cannot listen on the same port. Is the Mopidy service already running?

Does Mopidy normally run as a user service on Arch or is that something you’ve decided to try and do?


#3

Yes, I figured it out searching on forums, looks like mpd it’s running both times.
But I couldn’t kill both or at least one of mpd process so…:cry:
I tried:

 kill $(lsof -t -i:8080)
 mpd --no-daemon --stdout --verbose
 mpd --kill
 killall mpd

And other commands trying to kill that process but I gave up :confounded:

I tried running it as a system service and also as a user service but i had the same result

btw i followed this guide: https://gist.github.com/0x414A/11118592


#4

I’d always recommending using our docs rather than some person’s gist from years ago.

Use systemctl to stop mpd if it’s the problem. Or just change the MPD port that Mopidy is using to something else if you want to have them both running.