Mopidy Discourse

Need help for DLNA/UPNP setup with MPD

I have one DSM server with DLNA and UPNP service, I want to connect it with MPD and upmpdcli from this link UPnP — Mopidy 3.2.0 documentation

But I’m confused the mpd cannot enabled after I install by
python3 -m pip install Mopidy-MPD

[mpd]
enabled = true
hostname = 0.0.0.0
port = 2600
password = xxx
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname

The port 2600 is not listened when I check with ss -l | grep 2600

Here is service status

Jul 24 16:32:17 pve mopidy[176635]: INFO     [MainThread] mopidy.commands Starting Mopidy mixer: SoftwareMixer
Jul 24 16:32:17 pve mopidy[176635]: INFO     [MainThread] mopidy.commands Starting Mopidy audio
Jul 24 16:32:17 pve mopidy[176635]: INFO     [MainThread] mopidy.commands Starting Mopidy backends: FileBackend, M3UBackend, S>
Jul 24 16:32:17 pve mopidy[176635]: INFO     [Audio-2] mopidy.audio.actor Audio output set to "autoaudiosink"
Jul 24 16:32:17 pve mopidy[176635]: INFO     [MainThread] mopidy.commands Starting Mopidy core
Jul 24 16:32:17 pve mopidy[176635]: INFO     [MainThread] mopidy.commands Starting Mopidy frontends: MpdFrontend, IrisFrontend>
Jul 24 16:32:17 pve mopidy[176635]: INFO     [MainThread] mopidy_mpd.actor MPD server running at [::ffff:0.0.0.0]:2600
Jul 24 16:32:17 pve mopidy[176635]: INFO     [IrisFrontend-8] mopidy_iris.core Starting Iris 3.58.0
Jul 24 16:32:17 pve mopidy[176635]: INFO     [HttpFrontend-11] mopidy.http.actor HTTP server running at [::ffff:0.0.0.0]:2680
Jul 24 16:32:17 pve mopidy[176635]: INFO     [MainThread] mopidy.commands Starting GLib mainloop

I think mpdfrontend is not enough, shoud I install mpd server, but how could I configure them and work together? Any docs or link can help me?

The logs say that it’s working. You’ve got it set so you can only control it from the same machine though. Is that what you intended? If you want to control it from other devices on the network you’ll have to change hostname to allow that.

Have a look at docs:

1 Like

Even I changed hostname to 0.0.0.0 but the port is still not lisented

I want to use Iris to control mopidy and browse music from UPNP server with MPD and upmpdcli. But there is no docs about how to configure them work together

I’ve no explanation why the listening socket is not present. I’d personally try and actually connect.

There is documentation and it states

The default settings of upmpdcli will work with the default settings of Mopidy-MPD. Edit /etc/upmpdcli.conf if you want to use different ports, hosts, or other settings.

But it’s very possible this advice is out of date. We rely on users for keeping info on integrations like this up to date.

Alternatively, try Mopidy-dLeyna

Thank you for tips

I changed to default port number now upmpdcli and mopidy start up without any error and 6600 is listen now.

● upmpdcli.service - UPnP Renderer front-end to MPD
     Loaded: loaded (/lib/systemd/system/upmpdcli.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-07-24 23:19:18 CST; 13s ago
   Main PID: 2617 (upmpdcli)
      Tasks: 11 (limit: 16609)
     Memory: 2.5M
        CPU: 24ms
     CGroup: /system.slice/upmpdcli.service
             └─2617 /usr/bin/upmpdcli -c /etc/upmpdcli.conf

Jul 24 23:19:18 pve systemd[1]: Started UPnP Renderer front-end to MPD.
Jul 24 23:19:18 pve upmpdcli[2617]: :3:libupnpp/upnpplib.cxx:244::LibUPnP: Using IPV4 192.168.0.2 port 49152 IPV6  >
Jul 24 23:19:18 pve upmpdcli[2630]: writing RSA key

But I’m confused what’s next? I didn’t see any portal for UPNP service in iris.
Or I need other staff?

I tried dLeyna but got D-Bus X11 and DISPLAY error, after strugled for days I give up, so I’d like to try upmpdcli first.

Iris is mainly aimed at Spotify and Local extensions, and isn’t that great for others.

I tried Mopidy-dLeyna for a bit, but Restore State doesn’t work with it, so I’ve now switched to Mopidy-File for playing my own files.

If you really want to use Iris, you’ll probably want to use Mopidy-Local.

I want to use UPNP so that I can share one smart playlist for all devices, so I need work with upmpdcli

Well, just find some upmpdcli control client, such as BubbleUPNP, it work well with default config
Now I can control from iris to playback smartlist in my UPNP device.

So are you saying it does indeed work with the default config as per our docs? I had assumed you had a controller app…

The one problem is mpd only works with default port 6600, otherwise not listened.
Everything works well after install controller app

This has always worked for me, I use it frequently to run multiple instances of Mopidy (when testing) and have each instance listen on different ports for both HTTP and MPD.

I just tried it and it works fine. If you had actually tried connecting to the server as suggested you’d have also seen it works. What doesn’t work is your command ss -l | grep 2600. And that is because ‘2600’ is the port for zebrasrv (whatever that is) and ss helpfully substitutes ‘2600’ for ‘zebrasrv’ in the output which means your grep fails.

If you had to use ss you could have done sudo ss -lp | grep mopidy which would have worked:

tcp    LISTEN  0        1                                      [::ffff:0.0.0.0]:zebrasrv                                                   *:*                   users:(("mopidy",pid=13698,fd=27))

Or ss -ln | grep 2600 to disable service name resolution.

Yes, you are right, I just forgot ss use service name by default

Another thing is iris not support browse UPNP source?
So I have to use another control app, even installed mpd and upmpdcli they can connect DLNA/UPNP?

I think this question was already answered above, neither iris or Mopidy provides dlna controller functionality. I think that’s what you are asking. So Yeh, you need a separate DLNA controller app like bubble.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.