MusicBox + Chord Mojo


#1

Hello Guys,

I’m trying to use my Chord Mojo as external DAC with musicbox on a raspberry model B.
Unfortunately I can’t make it work.

With standard setup: I see my Mojo when I do aplay -l on card 1:

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 6/7
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Mojo [Mojo], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

Looking for an answer on internet I’ve seen many people changed the asound conf file setting sns_usb_audio to 0, but when I do that, my mojo disapears… (see below my current asound conf file setup)

autoloader aliases

install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

Cause optional modules to be loaded above generic modules

install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd$
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modp$
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modp$

Keep snd-pcsp from beeing loaded as first soundcard

options snd-pcsp index=-2

Keep snd-usb-audio from beeing loaded as first soundcard

options snd-usb-audio index=-2

Prevent abnormal drivers from grabbing index 0

One last thing: when I run alsamixer I see the mojo as below (on the screenshot) But no sound goes out of it.

Any advice to help me understand what’s hapenning (I’m still at the diagnosis step)
52

Many thanks


#2

So you’ve set the audio device to usb in settings.ini / websettings? Once you’ve done that (and only that), please provide the log at /var/log/musicbox_startup.log.


#3

Hello,

I tried changing audio device to usb and here the output:


Initializing MusicBox…


Setting sound configuration…
Probing sound devices:

  • Found internal device: card0
  • Found internal device: card0
  • Found usb device: card1
    Selected card=1 (i2s= output=usb usb=1 intc=0)
    Using audio card1 (usb)
    MusicBox name is MusicBox
    Stopping Samba daemons: nmbd smbd.
    Starting Samba daemons: nmbd smbd.
    Starting Dropbear SSH server: dropbear.
    Starting daemon monitor: monit.
    Scanning music-files, please wait…
    INFO Starting Mopidy 1.1.2
    INFO Loading config from builtin defaults
    INFO Loading config from /etc/mopidy/mopidy.conf

It seems to detect the usb device, but no sound goes out of it…

Any idea?