MusicBox and PhatDac


#21

I’m headed out of town for the weekend, will test on Monday.

Thanks.

Phil


#22

Don’t turn on the firewall or spotify-connect wont work out of the box.


#23

Thanks, I’ll sort that out when I get a chance.


#24

Still no sound… did a full fresh install of rc5, chose PhatDac from the settings, restarted and still nothing…

If I boot from Noobs and install the PhatDac drivers I can get it to play a sound…

Any other thoughts?

Could it be something to do with my HDMI monitor?

Any other tests you would like me to try?

Thanks

Phil


Which DAC for Mopidy?
#25

I did exactly this yesterday with my phatdac and my Pi Zero W v1.1 without issue: installed rc5, booted, selected phatdac from websettings and rebooted. I presume you’ve already tried removing the HDMI cable by now?

Could you paste the contents of your /var/log/musicbox_startup.log file? Mine is one of the first phatdacs so I guess it’s possible something has changed but I can’t see that’s the case. There really is nowhere for this to go wrong, it’s so simple!


#26

I tried it without the HDMI…

Here is the log. I do see an error…

Thanks for all your help.

Phil

______ _    _______            _       ______             
(_____ (_)  (_______)          (_)     (____  \            
 _____) )    _  _  _ _   _  ___ _  ____ ____)  ) ___ _   _ 
|  ____/ |  | ||_|| | | | |/___) |/ ___)  __  ( / _ ( \ / )
| |    | |  | |   | | |_| |___ | ( (___| |__)  ) |_| ) X ( 
|_|    |_|  |_|   |_|____/(___/|_|\____)______/ \___(_/ \_)

Welcome!

root@MusicBox:~# cat /var/log/musicbox_startup.log
************************
Initializing MusicBox...
************************
Setting sound configuration...
* Found internal device: card0
* Found internal device: card0
* Found unknown device 'sndrpihifiberrydac' on card1
* Found internal device: card0
* Found internal device: card0
* Found i2s device: card1
Card=1  i2s=1  output=hifiberry_dac  usb=1  intc=0
Card=1  i2s=1  output=hifiberry_dac  usb=1  intc=0
Using audio card1 (hifiberry_dac)
MusicBox name is MusicBox
ifup: interface wlan0 already configured
Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
Reconfiguring network interfaces...Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/b8:27:eb:44:eb:4b
Sending on   LPF/wlan0/b8:27:eb:44:eb:4b
Sending on   Socket/fallback
DHCPRELEASE on wlan0 to 192.168.86.1 port 67
Reloading /etc/samba/smb.conf: smbd only.
done.
Stopping Samba daemons: nmbd smbd.
Starting Samba daemons: nmbd smbd.
Starting Dropbear SSH server: dropbear.
Starting daemon monitor: monit.
Scanning music-files, please wait...
INFO     Starting Mopidy 1.1.2
INFO     Loading config from builtin defaults
INFO     Loading config from /etc/mopidy/mopidy.conf
INFO     Loading config from command line options
***********************************************************************************
My IP address is 192.168.86.100
Connect to me in your browser at http://MusicBox.local or http://192.168.86.100
***********************************************************************************
root@MusicBox:~#

#27

Where’s the error? That looks OK to me.


#28

I thought that the “unknown device” messag looked like an error.

Any other clues in this log?

Are there any other logs that could help?

Cheers

Phil


#29

For historical reasons, it does two passes through the sound devices. the first pass only looks for the onboard sound cards and doesn’t know what to make of your ‘sndrpihifiberrydac’ card. But that’s fine and expected, the next pass knows to look for it and correctly recognises it as an i2s device on card 1. And then it uses it, which writes /etc/asound.conf with card1 as the default, you showed earlier that this file has the correct content:

pcm.!default {
type hw
card 1
}
ctl.!default {
type hw
card 1
}

Once it’s done that, it should output something when you run /usr/share/sounds/alsa/Front_Center.wav.

Do you have a HDMI tv you can try and get audio through? Or a usb soundcard?


#30

I know you have confirmed your phatdac works with noobs but I’m just entirely out of ideas and just want something to be working.


#31

Thanks, I’ll plug it into a my TV tomorrow and report back.

Phil


#32

It worked great through the HDMI on my TV.

I booted into MusicBox, changed the audio output to HDMI, rebooted and it worked…

Still nothing from my PhatDac though.


#33

When you had it working with noobs did you follow their guide or did you run their installation script?


#34

I ran the script on this page.

https://learn.pimoroni.com/tutorial/phat/raspberry-pi-phat-dac-install

Phil


#35

Ok… weird… I can’t get the PhatDac to work at all now…

I tried Noobs and also Raspian… I did have it workig when I first got the PhatDac.

I’ll try and debug it with the PhatDac people and hopefully MusicBox will also work then.

I’ll report back.


#36

Ok that’s an interesting development. The pimoroni people are brilliant so hopefully they’ll get it sorted (or replaced) for you quickly.


#37

Ok… not sure what was going on but it seems like I have it working now.

I could have been a connection issue, not sure but it seems like everything is great now…

Thanks for your support.

Phil


#38

Hi Phil,
What was the issue? I think I have the same ((((


#39

@ras22 It was actually a hardware issue with the pins not being seated correctly.

Phil