MPD in mopidy: mpc connects but does not show playing track


When I run ‘mpc’, I only get the line:

volume: 98% repeat: on random: off single: off consume: off

even when a song is playing. So mpc is connecting to the mpd server but not getting the full information.

I found that I have a service ‘mpd’ running which is even running when I stop the service ‘mopidy’. When I stop ‘mpd’ and have ‘mopidy’ running, mpc is not connecting anymore. Is this extra ‘mpd’ service part of the mopidy installation?

What’s going wrong with my mpd server?

I run mopidy 2.0.1 on Raspbian Jessie.
Here is my config:

No, that sounds like you also have the mpd program installed and running. Mopidy’s MPD compatible server runs within the mopidy service.

Your config looks fine so I would guess that Mopidy’s MPD server was not able to start because mpd 's server had already started on port 6600 (only one process can bind to a particular port at a time). You should have seen an error message reporting this in Mopidy’s log. Have you tried leaving mpd disabled/stopped and restarting mopidy?

Just stopping mpd and restarting mopidy was not enough but removing the mpd package worked. Thanks!

Hmm, not sure I understand why but glad it’s working.

I am using snapcast and this extra mpd server seems to be part of that, since snapcast is not running without it. But changing the port of mopidy-mpd to something else lets me access it with mpc.