Mpc timeout error port:6680 host:localhost

Hello, I have installed mopidy and it runs on 127.0.0.1:6680. I can access the mopidy website on localhost:6680. I have also successfully installed the iris web client extension.

My main goal is to listen to soundcloud via mopidy. I haven’t found a client that supports soundcloud yet, so I just try to listen to it with mpc.

But I don’t know what’s wrong. I added this to my enironment variables:
MPD_HOST=127.0.0.1
MPD_PORT=6680
Now, when I run mpc, I get the following error, after a while:
MPD error: Timeout
I have no music on my local hard drive. I just run mpc to check if the command works with mopidy.

I have read in another forum thread here, that it is possible to listen to Soundcloud via mopidy-soundcloud and mpc.

Thanks for any help.
L

Have you installed the Mopidy-mpd extension? It isn’t included in Mopidy core anymore.

Are you running mpc on the same Pi, or from somewhere else on the network? The default configuration only allows connection on localhost.

This is my Mopidy config for the MPD extension, which allows connection from

[mpd]
enabled = true
hostname = 0.0.0.0

More about configuration here: GitHub - mopidy/mopidy-mpd: Mopidy extension for controlling playback from MPD clients

That’s the wrong port. The default MPD port is 6600. But regardless, if you are running mpc and Mopidy on the same computer you don’t need to specify the host or the port. You do need to ensure Mopidy-MPD is installed, as already stated.

I’m not sure Mopidy-soundcloud currently works. Soundcloud seem determined to do as much useless busy-work as possible whilst leaving their API fundamentally broken.

Thanks for your replies.
I have now installed mopidy-mpd. But mpc says warning: MPD 0.21 required.
As long as it’s just a warning…
Soundcloud. Well, I want to hide from Spotify.