Mopidy touchscreen pitft pi 3


#1

hello, I am using mopidy with the following config:

  • raspbian jessie with latest updates
  • raspberry pi 3
  • adafruit pitft 2.8" resistive touchscreen
  • mopidy version 2.0.1
  • develop branch of gmusic plugin
  • develop branch of mopidy-touchscreen

everything is working quite well with just the basic suggested config. however, the touchscreen is input is off. i can see that something is happening and it seems like left-to-right position almost works but the cursor always stays at the top.

I saw another thread about issues with the pitft but it is an old thread and none of the details matched up with “severe pointer misalignment”. is this a known current issue?

thanks,
Greg


#2

You could check this thread.

The thread is not exactly for the Adafruit piftf but I think that the calibration and testing should work on your display. (Starting from “In order to use the touch panel with python, X, and to calibrate it, a few packages need loading”)

I had a problem in the past with my touchscreen. The Y axis of the touchscreen was reversed and the calibration from that thread solved it.


#3

hey @greg_frank how did you get mopidy and the touchscreen working on rPi3?
i used adafruits pitft28c image and have the console echoing to the 2.8" screen
i have mopidy 2.1.0 running and playing music but when i install “pip install Mopidy-Touchscreen” and put the relevant lines in the mopidy conf, nothing happens when i run mopidy except the normal status lines show

but then again im not sure what is supposed to happen. nowhere that i can find does anyone mention how to implement the touchscreen interface other than how to install it. but how do i SEE it. is the screen supposed to change on my local rpi3 screen to the touchscreen frontend or is this another client to be run from another machine?

anything to send me in the right direction appreciated… i know im missing something simple.


#4

I never got this working and gave up. Also, I got frustrated with the Pi and ARM-based solutions in general and switched to a Zotac CI327.

Currently running the home Mopidy (plus some other things) on ordinary Ubuntu Linux. Switching to an x86 processor gave access to the latest version of every possible package with vastly improved performance. Not one single regret about the switch!