Mopidy-spotify on Stretch


#1

I have just installed stretch-lite on a pi3

Did a dist-upgrade, then installed mopidy, mpc and pip.

Tried to install mopidy-spotify and encountered an error with libffi not found.

Any ideas?

Pete


#2

Think i had the same thing. Might be a missing dependency?
Using ’ sudo apt-get install mopidy-spotify’ solved it for me.


#3

Hi, thanks for a quick response, will try it.


#4

Nope, there is no mopidy-spotify in the stretch repo, so I am going back to building from a Jessie noobs, I know that works - well it did on a pi1b yesterday.


#5

What exactly did you try? Did you add the Mopidy apt repository and install mopidy-spotify using apt? Or did you try and install mopidy-spotify from pip? The latter won’t work unless you first install the non-python dependencies, as the pyspotify documentation specifies.


#6

Tried pip.
Apt-cache search mopidy finds mopidy and a bunch of mopidy modules, but not mopidy-spotify. I had kinda assumed that all mopidy packages are in the pi stretch repo.


#7

It finds both on my pi:
pi@raspberrypi:~ $ apt-cache search mopidy-spotify
mopidy-spotify - Mopidy extension for playing music from Spotify
mopidy-spotify-tunigo - Mopidy extension for provid
ing the browse feature of Spotify
pi@raspberrypi:~ $


#8

You need to add the Mopidy Apt repository, instructions are at https://docs.mopidy.com/en/latest/installation/debian/


#9

Thanks for that, added repo, success

I had a Noobs card which came with a pi zero - which has noobs 1.3 May 2017 (jessie)
I installed that on a RP1b and got mopidy-spotify up and running using apt.
Doing apt-get search mopidy shows mopidy and mopidy spotify plus a bunch of other extns. The sources.list only shows the Pi repos. no refs to mopidy anywhere in /etc/apt.

I installed stretch lite after downloading the image from the Pi download site. Mopidy plus a bunch of extns are in the stretch repos but not mopidy spotify.

hit head against nearest wall!!

Pete