Mopidy-spotify no longer there?


#1

Hey everyone,

New to mopidy and RP in general but I can’t seem to locate the mopidy-spotify extension. Has that been removed?

sudo apt-get install mopidy-spotify
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package mopidy-spotify

The docs don’t list mopidy-spotify as an extension either.

Any pointers in the right directions will help.

Thank you!


#2

No, it has not been removed. It’s listed in the docs: https://docs.mopidy.com/en/latest/ext/backends/#mopidy-spotify

Steps 1 to 3 of the installation instructions should work just fine. Did you do sudo apt-get update as per step 3?


#3

sudo apt-get install Mopidy-spotify
Make sure to capitalize Mopidy!


#4

No, this is wrong. The documentation was, and still is, correct.


#5

No. You are incorrect. I just followed the install steps and had to capitalize Mopidy in Mopidy-spotify for it to install properly.


#6

What operating system are you running?


#7

And if you don’t mind, the output of apt-cache -f search opidy-spotify


#8

Hey, I’ve done this and I still don’t see mopidy-spotify as an option when I run apt-cache search mopidy. Any tips?


#9

What system are you running and what’s the output of apt-cache policy | grep http ?


#10

Raspberry Pi
pi@raspberrypi:~ $ apt-cache policy | grep http 500 http://archive.raspberrypi.org/debian stretch/ui armhf Packages 500 http://archive.raspberrypi.org/debian stretch/main armhf Packages 500 http://raspbian.raspberrypi.org/raspbian stretch/rpi armhf Packages 500 http://raspbian.raspberrypi.org/raspbian stretch/non-free armhf Packages 500 http://raspbian.raspberrypi.org/raspbian stretch/contrib armhf Packages 500 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages


#11

I do not see http://apt.mopidy.com listed in there. Are you really sure you have followed the first 3 steps at https://docs.mopidy.com/en/latest/installation/debian/ ?


#12

I ran through the steps again, and it’s working now. Thanks for your help.