Mopidy does not connect to mpd frontend


#1

Folks,

I’ve been trying to get Mopidy running. It runs but i can’t get any mpd front end to connect to it. i get an “mpd error: Connection refused” when i try an ‘mpc playlist’

I already have a large music collection in beets, so i’d like to utilize that database. I have ‘beets web’ running successfully.
I see the warnings below, but since i have the beets plugin loaded, do i still need to create the local library, and set a directory for it? Shouldn’t mopidy be getting this information from the beets database?

INFO Starting Mopidy 2.1.0 20:57:37
INFO Loading config from builtin defaults
INFO Loading config from /home/moonwind/.config/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: mpd, alsamixer, http, beets, stream, m3u, softwaremixer, file, local
INFO Disabled extensions: none
INFO Starting Mopidy mixer: AlsaMixer
INFO Mixing using ALSA, card 0, mixer control “Master”.
INFO Starting Mopidy audio
INFO Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend, BeetsBackend
INFO Audio output set to “autoaudiosink”
WARNING /home/moonwind/Music is not a directory. Please create the directory or update the file/media_dirs config value.
WARNING Local media dir /home/moonwind/Music does not exist or we lack permissions to the directory or one of its parents
WARNING Local media dir /home/moonwind/Music does not exist or we lack permissions to the directory or one of its parents
INFO No local library metadata cache found at /home/moonwind/.local/share/mopidy/local/library.json.gz. Please run mopidy local scan to index your local music library. If you do not have a local music collection, you can disable the local backend to hide this message.
INFO Loaded 0 local tracks using json
INFO Connecting to Beets remote library http://127.0.0.1:8889
INFO Starting Mopidy core
INFO Loading state from /home/moonwind/.local/share/mopidy/core/state.json.gz
INFO Starting Mopidy frontends: MpdFrontend, HttpFrontend
INFO MPD server running at [::]:6600
INFO HTTP server running at [::ffff:127.0.0.1]:6680
INFO Starting GLib mainloop

My config:
[mpd]
hostname = ::
enabled = true
#hostname = 127.0.0.1
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = listall,listallinfo
default_playlist_scheme = m3u%

[core]
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000
restore_state = true

[logging]
color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n %(message)s
debug_file = mopidy.log
config_file =

[audio]
mixer = alsamixer
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[alsamixer]
card = 0
control = Master

[beets]
hostname = 127.0.0.1
#port = 8337

changed port for nginx proxy to allow seeking in files

port = 8889

Thanks all


#2

not a full solution, but try Rompr (can run without Mysql), it supports beets as well as all mpd stuff too. It is a separate web app frontend for Mpd/Mopidy


#3

I’ll investigate that, but i’m a cli user, so mpc is my goto.


#4

Also @germain can’t get mopidy to connect to any front-end, so Rompr wouldn’t do any good to me anyhow.

The issue is, i get an “mpd error: Connection refused” when i try any mpd front-end, so there is something amiss in my settings. Any help is appreciated.


#5

Hmm a puzzler this. Your mpd config looks good. Your startup log looks good (I guess you can just disable the local extension since you are not using it). And you are running mpc playlist on the same machine as you have installed mopidy, right? If not, you’d obviously need to provide the address to use. Can you try using netstat to verify the Mopidy process is really listening on port 6600? Are you running any firewall software on this machine?


#6

Put a real ip for mpd, I had issues with mpd and some other apps when I use run on all interfaces type thing

what I use

[mpd]
enabled = true
hostname = 192.168.1.1
port = 6600

also check lsof -i to see what ports are avail to you