Mopidy Discourse

Connection refused from remote MPD access

Hello,

I am having trouble getting a remote Mopidy server running. I’ve installed mopidy on an ubuntu server VM

I am able to browse the files from the sonata client, but when I attempt to play, it just goes on silently as if it’s playing. I also get this in the service logs:

[MainThread] mopidy.audio.gst GStreamer warning: Failed to connect: Connection refused

I ran nmap against port 6600 and it says open so it is unlikely to be a firewall issue. The music folder and files are owned by mopidy:audio and with chmod 755.

I am out of ideas. What else could be causing this behavior?

Thanks,

mopidyctl config
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
verbosity = 0
format = %(levelname)-8s [%(threadName)s] %(name)s %(message)s
color = false
config_file =

[audio]
mixer = software
mixer_volume = 
output = autoaudiosink
buffer_time = 

[proxy]
scheme = 
hostname = 
port = 
username = 
password = 

[file]
enabled = true
media_dirs = 
  /srv/mopidy|Local
excluded_file_extensions = 
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .pdf
  .png
  .txt
  .zip
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[http]
enabled = true
hostname = ::
port = 6680
zeroconf = Mopidy HTTP server on $hostname
allowed_origins = 
csrf_protection = true
default_app = mopidy

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

[softwaremixer]
enabled = true

[stream]
enabled = true
protocols = 
  http
  https
  mms
  rtmp
  rtmps
  rtsp
metadata_blacklist = 
timeout = 5000

[mpd]
enabled = true
hostname = ::
port = 6600
password = 
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = 
  listall
  listallinfo
default_playlist_scheme = m3u

Where are you expecting to hear the audio from? Is this remote server within hearing distance?

I’m trying to access the mopidy server from a desktop computer on the same LAN but different machine. I ran the same configs on localhost and can play no problem, but it won’t work when trying to access from a separate computer.

This connection error is from gstreamer. I’d normally guess it’s unable to connect to your pulseaudio server to play the audio. There’s a section on pulse config in the service docs. But that doesn’t fit with what you say about having it work when accessing locally…

I should say that the same config worked on my desktop, which runs Ubuntu Desktop. The server is Ubuntu server edition, which has no GUI components installed right now. Could the server edition be missing dependencies that are not picked up by APT?

I would try logging onto your server (via ssh or whoever you normally do that) and manually starting pulseaudio either by starting the pulseaudio user service or by testing the audio output with something like aplay (in which case that action itself should start pulseaudio automatically). Then try controlling Mopidy again.

This does assume Ubuntu server uses pulseaudio. I’ve no idea. Ideally not.

Ah I think I misunderstood how Mopidy works. I’ve been trying to set it up as a “server” like a personal Spotify service to stream to client devices, but it plays music via the home machine’s audio output?

Correct. Audio output is from the same machine running Mopidy. Clients are for contol only.

Some people use Mopidy along with snapcast to achieve audio output on remote machines. Pulseaudio can also be made to do this. Technically icecast also but personally I would avoid that. All these options require extra software/configuration.

What’s your reason for avoiding Icecast? It seems more geared towards the “self-hosted music service” use case than the other options. I haven’t tried any of them yet myself.

https://docs.mopidy.com/en/latest/icecast/