Installed mopidy 2.0 and installed gstreamer1.0 but still GStreamer too old - SOLVED


Any idea how to get latest GStreamer on rasberry 2 ?

I have installed gstreamer1.0 and the required library’s

root:~# mopidy --version
ERROR: Mopidy requires GStreamer >= 1.2.3, but found GStreamer 1.2.0.

root:~# uname -a
Linux MusicBox 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l GNU/Linux

root:~# cat /etc/issue
MusicBox 0.6RC

root:~# gst-launch-1.0 --version
gst-launch-1.0 version 1.2.0
GStreamer 1.2.0

You’re running Pi Musicbox 0.6, which is based on Raspbian Wheezy.

wheezy-backports has GStreamer 1.2.4, and we know we need bug fixes from 1.2.3, thus we require 1.2.3. I was under the belief that wheezy-backports would make installing Mopidy 2.0 achievable on Wheezy systems, but it looks like Raspbian hasn’t rebuilt the wheezy-backports dist for the Raspberry Pi CPU architecture.

I don’t have a simple solution for you, and would rather spend my time on helping with making a new Pi Musicbox release.

Musicbox has these two mirrors, aside from

The first one doesn’t contain GStreamer 1.x at all. The second only seems to include version 1.2.0, while we now require at least 1.2.3.

Since you have a Raspberry PI 2, you should be able to solve this by adding the mirror:

deb wheezy-backports main

And run an upgrade.

The other possible solution would be to upgrade to jessie.

I upgrade by adding deb . main

# gst-launch-1.0 --version
gst-launch-1.0 version 1.2.4
GStreamer 1.2.4
# mopidy --version
Mopidy 2.0.0

mopidy starts but something i not OK, there is eror in log

2016-02-16 11:39:25,887 INFO [9104:MainThread] mopidy.commands: Starting Mopidy mixer: SoftwareMixer
2016-02-16 11:39:25,894 INFO [9104:MainThread] mopidy.commands: Mixer volume set to 100
2016-02-16 11:39:25,896 INFO [9104:MainThread] mopidy.commands: Starting Mopidy audio
2016-02-16 11:39:25,902 INFO [9104:MainThread] mopidy.commands: Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend, SomaFMBackend, TuneInBackend, PodcastBackend, SpotifyTunigoBackend
2016-02-16 11:39:25,973 INFO [9104:Audio-2] Audio output set to "alsasink buffer-time=200000 latency-time=10000"
2016-02-16 11:39:25,978 ERROR [9104:Audio-2] pykka: Unhandled exception in Audio (urn:uuid:76a23e59-5fec-40e2-8ad4-11d1e4bc604f):
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pykka/", line 192, in _actor_loop
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/", line 431, in on_start
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/", line 484, in _setup_outputs
  File "/usr/local/lib/python2.7/dist-packages/mopidy/audio/", line 193, in setup_event_handling
    Gst.PadProbeType.EVENT_BOTH, self.on_pad_event)
  File "/usr/lib/python2.7/dist-packages/gi/", line 113, in function
    return info.invoke(*args, **kwargs)
TypeError: add_probe() takes exactly 4 arguments (3 given)
2016-02-16 11:39:26,069 INFO [9104:MainThread] mopidy.local.library: Loaded 2 local tracks using sqlite
2016-02-16 11:39:26,119 INFO [9104:SomaFMBackend-7] requests.packages.urllib3.connectionpool: Starting new HTTPS connection (1):
2016-02-16 11:39:26,124 INFO [9104:MainThread] mopidy_podcast.backend: Starting Mopidy-Podcast directories: FeedsDirectory, iTunesDirectory, GPodderDirectory
2016-02-16 11:39:26,142 INFO [9104:MainThread] mopidy_podcast.backend: Refreshing Mopidy-Podcast directories
2016-02-16 11:39:26,153 INFO [9104:PodcastDirectoryActor-10] requests.packages.urllib3.connectionpool: Starting new HTTP connection (1):
2016-02-16 11:39:26,313 WARNING [9104:SomaFMBackend-7] py.warnings: /usr/local/lib/python2.7/dist-packages/requests/packages/urllib3/util/ SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension to TLS is not available on this platform. This may cause the server to present an incorrect TLS certificate, which can cause validation failures. For more information, see

add_probe() does indeed take a user_data argument we don’t pass to it, but that should be optional. I suspect that you hasn’t installed python-gst-1.0 which includes overrides to the GI provided API to make it better to work with.

I upgrade to jessie and now i get core dump when i start mopedy
missing some library ?

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/arm-linux-gnueabihf/".
Core was generated by `/usr/bin/python /usr/local/bin/mopidy --version'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x7631c78c in gi_gst_register_types () from /usr/lib/python2.7/dist-packages/gi/overrides/
(gdb) Quit
(gdb) bt
#0  0x7631c78c in gi_gst_register_types () from /usr/lib/python2.7/dist-packages/gi/overrides/
#1  0x7631c898 in init_gi_gst () from /usr/lib/python2.7/dist-packages/gi/overrides/
#2  0x0010a360 in _PyImport_LoadDynamicModule ()
#3  0x00067d5c in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Do you know only have packages from Raspbian Jessie or is there a mix of packages from Raspbian armhf (ARMv6++) and Debian armhf (ARMv7)?

i did upgrade from deb jessie main contrib non-free rpi and

Origin: Raspberry Pi Foundation
Label: Raspberry Pi Foundation
Suite: stable
Codename: jessie
Date: Tue, 09 Feb 2016 16:21:05 UTC
Architectures: armhf

root:/usr/share/mopidy# file /usr/bin/python2.7
/usr/bin/python2.7: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/, for GNU/Linux 2.6.32, BuildID[sha1]=c25407fddc7a86e41aad162aa07c89e029ecc6f3, stripped

root@# ldd /usr/bin/python2.7 (0x7edd2000)
/usr/lib/arm-linux-gnueabihf/ (0x76f90000) => /lib/arm-linux-gnueabihf/ (0x76f58000) => /lib/arm-linux-gnueabihf/ (0x76f45000) => /lib/arm-linux-gnueabihf/ (0x76f32000) => /lib/arm-linux-gnueabihf/ (0x76f0b000) => /lib/arm-linux-gnueabihf/ (0x76e90000) => /lib/arm-linux-gnueabihf/ (0x76d4e000)
/lib/ (0x54ac2000)

Components: main ui staging untested
Description: Packages for the Raspberry Pi

I downgraded mopidy to 1.1.2 and now does mopidy start as service but not mopidy-spotify does not work
I think mine problem is in pip because i have lot of errors, how to reinstall pip ?

2016-02-16 21:19:22,536 WARNING [6567:MainThread] mopidy.__main__: Found alsamixer configuration errors, the extension has been automatically disabled:
2016-02-16 21:19:22,539 WARNING [6567:MainThread] mopidy.__main__: Found mopify configuration errors, the extension has been automatically disabled:
2016-02-16 21:19:22,541 WARNING [6567:MainThread] mopidy.__main__: Please fix the extension configuration errors or disable the extensions to silence these messages.
2016-02-16 21:19:22,981 ERROR [6567:MainThread] mopidy.__main__: Extension stream failed during setup, this might have left the registry in a bad state.
AttributeError: 'CompiledFFI' object has no attribute 'def_extern'
2016-02-16 21:19:23,028 ERROR [6567:MainThread] mopidy.__main__: Extension somafm failed during setup, this might have left the registry in a bad state.
AttributeError: 'CompiledFFI' object has no attribute 'def_extern'
2016-02-16 21:19:23,054 ERROR [6567:MainThread] mopidy.__main__: Extension tunein failed during setup, this might have left the registry in a bad state.
AttributeError: 'CompiledFFI' object has no attribute 'def_extern'
2016-02-16 21:19:23,222 ERROR [6567:MainThread] mopidy.__main__: Extension podcast-itunes failed during setup, this might have left the registry in a bad state.
AttributeError: 'CompiledFFI' object has no attribute 'def_extern'
2016-02-16 21:19:23,248 ERROR [6567:MainThread] mopidy.__main__: Extension spotify_tunigo failed during setup, this might have left the registry in a bad state.
AttributeError: 'CompiledFFI' object has no attribute 'def_extern'
2016-02-16 21:19:23,270 ERROR [6567:MainThread] mopidy.__main__: Extension podcast-gpodder failed during setup, this might have left the registry in a bad state.
AttributeError: 'CompiledFFI' object has no attribute 'def_extern'

upgraded back to latest but mopidy-spotify has strange version pip vs apt-get

CherryPy (3.5.0) - Latest: 5.0.1 [sdist]
colorama (0.3.2) - Latest: 0.3.6 [wheel]
decorator (4.0.6) - Latest: 4.0.9 [wheel]
gmusicapi (7.0.0) - Latest: 8.0.0 [sdist]
gpsoauth (0.0.4) - Latest: 0.2.0 [sdist]
html5lib (0.999) - Latest: 0.9999999 [sdist]
Jinja2 (2.7.3) - Latest: 2.8 [wheel]
Mopidy-Dirble (1.2.0) - Latest: 1.3.0 [sdist]
Mopidy-Mopify (1.5.14) - Latest: 1.5.15 [sdist]
Mopidy-MusicBox-Webclient (2.0.0) - Latest: 2.1.1 [wheel]
Mopidy-SomaFM (0.8.0) - Latest: 1.0.1 [sdist]
Mopidy-SoundCloud (2.0.0) - Latest: 2.0.2 [wheel]
Mopidy-Spotify (1.4.0) - Latest: 3.0.0 [wheel]
Mopidy-TuneIn (0.2.2) - Latest: 0.3.0 [wheel]
oauth2client (1.5.2) - Latest: 2.0.0 [sdist]
pafy (0.3.74) - Latest: 0.4.3 [wheel]
ply (3.4) - Latest: 3.8 [sdist]
py-sonic (0.3.4) - Latest: 0.4.1 [sdist]
pyalsaaudio (0.7) - Latest: 0.8.2 [sdist]
pycountry (1.15) - Latest: 1.20 [sdist]
pycparser (2.10) - Latest: 2.14 [sdist]
pycurl (7.19.5) - Latest: 7.43.0 [sdist]
pylast (1.1.0) - Latest: 1.5.1 [sdist]
pyspotify (1.12) - Latest: 2.0.5 [sdist]
pytz (2015.2) - Latest: 2015.7 [wheel]
requests (2.7.0) - Latest: 2.9.1 [wheel]
Routes (2.0) - Latest: 2.2 [wheel]
urllib3 (1.9.1) - Latest: 1.14 [wheel]
urwid (1.3.0) - Latest: 1.3.1 [sdist]
Whoosh (2.6.0) - Latest: 2.7.2 [wheel]
root@~# pip install --upgrade Mopidy-Spotify
Collecting Mopidy-Spotify
  Using cached Mopidy_Spotify-3.0.0-py2.py3-none-any.whl
Requirement already up-to-date: Mopidy>=2.0 in /usr/local/lib/python2.7/dist-packages (from Mopidy-Spotify)
Collecting requests>=2.0 (from Mopidy-Spotify)
  Using cached requests-2.9.1-py2.py3-none-any.whl
Requirement already up-to-date: Pykka>=1.1 in /usr/local/lib/python2.7/dist-packages (from Mopidy-Spotify)
Collecting pyspotify>=2.0.5 (from Mopidy-Spotify)
  Using cached pyspotify-2.0.5.tar.gz
Could not import setuptools which is required to install from a source distribution.
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pip/req/", line 375, in setup_py
    import setuptools  # noqa
  File "/usr/local/lib/python2.7/dist-packages/setuptools/", line 11, in <module>
    from setuptools.extern.six.moves import filterfalse, map
  File "/usr/local/lib/python2.7/dist-packages/setuptools/extern/", line 1, in <module>
    from pkg_resources.extern import VendorImporter
ImportError: No module named extern
root@:~# apt-get install Mopidy-Spotify
Reading package lists... Done
Building dependency tree
Reading state information... Done
mopidy-spotify is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@Bladelius:~# dpkg -l | grep -i spotify
ii  libspotify12                          12.1.103-0mopidy1                 armhf        Library for using the Spotify music streaming service
ii  mopidy-spotify                        3.0.0-0mopidy1                    all          Mopidy extension for playing music from Spotify
ii  python-spotify                        2.0.5-0mopidy1                    armhf        Python bindings for libspotify (Python 2)

reinstalled and removed dist-packages, no coredump.

apt-get remove python2.7
rm -rf /usr/local/lib/python2.7/dist-packages/
apt-get install mopidy
apt-get install mopidy-spotify

root@:/etc/mopidy# mopidy --version
Mopidy 2.0.0

Ok, that was quite a bold move to temporarily remove python2.7 as large parts of a typical Linux distro depends on Python. But if it worked, great! :slight_smile: