Python-gst-1.0 in Raspbian?


I couldn’t find the package python-gst-1.0 in Raspbian (wheezy and jessie). Is there another way how to install it? The other gstreamer1.0 packages are there.

ok I found this repo where they have python-gst-1.0:

deb . main

I tried to run the mopidy dev 2.0 with that installed but I still get this:

Traceback (most recent call last): File "/root/.virtualenvs/mopidy/bin/mopidy", line 9, in <module> load_entry_point('Mopidy', 'console_scripts', 'mopidy')() File "/root/.virtualenvs/mopidy/local/lib/python2.7/site-packages/pkg_resource s/", line 549, in load_entry_point return get_distribution(dist).load_entry_point(group, name) File "/root/.virtualenvs/mopidy/local/lib/python2.7/site-packages/pkg_resource s/", line 2709, in load_entry_point return ep.load() File "/root/.virtualenvs/mopidy/local/lib/python2.7/site-packages/pkg_resource s/", line 2369, in load return self.resolve() File "/root/.virtualenvs/mopidy/local/lib/python2.7/site-packages/pkg_resource s/", line 2375, in resolve module = __import__(self.module_name, fromlist=['__name__'], level=0) File "/root/mopidy-dev/mopidy/mopidy/", line 8, in <module> from import Gst # noqa: Import to initialize File "/root/mopidy-dev/mopidy/mopidy/internal/", line 9, in <module> gi.require_version('Gst', '1.0') File "/usr/lib/python2.7/dist-packages/gi/", line 73, in require_ve rsion raise ValueError('Namespace %s not available' % namespace) ValueError: Namespace Gst not available

Sorry, the docs are wrong. It should be gst-python-1.0 with an extra dash.

I was wrong, there is python-gst-1.0 in Raspbian Jessie (I could not find gst-python-1.0 though.).

I installed python-gst-1.0 in Raspbian Jessie but I still get the same error. Do I need something else?

Actually, the docs where right all along, and I just researched to little while on my phone.

You should get all you need by running:

sudo apt-get install python-gst-1.0 gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-tools

I had those installed already.

These two packages were still missing:


I installed them and now it works.

Both of those are dependencies of python-gst-1.0, so you should already have them installed after installing that one.

i have the same error but in macOS and do you know if the packets mentioned here are available for macOS ? thank you!

i already solved this: brew install gst-python