Http ports not opening on successful boot


#1

Fresh install on Ubuntu 18.04lts, the config looks right.

Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config” as user mopidy
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n %(message)s
debug_file = /var/log/mopidy/mopidy-debug.log
config_file = /etc/mopidy/logging.conf

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[mpd]
enabled = false ; Extension disabled by user config.

[http]
enabled = true
hostname = ::
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true

[stream]
enabled = true
protocols =
http
https
mms
rtmp
rtmps
rtsp
metadata_blacklist =
timeout = 5000

[m3u]
enabled = false ; Extension disabled by user config.

[softwaremixer]
enabled = true

[file]
enabled = true
media_dirs =
$XDG_MUSIC_DIR|Music
~/|Home
excluded_file_extensions =
.jpg
.jpeg
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[local]
enabled = false ; Extension disabled by user config.

[spotify]
enabled = true
username = yupthisisright
password = ********
client_id = itlikesthistoo
client_secret = ********
bitrate = 160
volume_normalization = true
private_session = false
timeout = 10
allow_cache = true
allow_network = true
allow_playlists = true
search_album_count = 20
search_artist_count = 10
search_track_count = 50
toplist_countries =

So far, so good, logs?

2019-02-13 19:32:53,235 INFO [13574:MainThread] mopidy.main: Starting Mopidy 2.2.1
2019-02-13 19:32:53,243 INFO [13574:MainThread] mopidy.config: Loading config from builtin defaults
2019-02-13 19:32:53,244 INFO [13574:MainThread] mopidy.config: Loading config from /etc/mopidy/mopidy.conf
2019-02-13 19:32:53,244 INFO [13574:MainThread] mopidy.config: Loading config from command line options
2019-02-13 19:32:53,269 INFO [13574:MainThread] mopidy.main: Enabled extensions: spotify, softwaremixer, http, file, stream
2019-02-13 19:32:53,269 INFO [13574:MainThread] mopidy.main: Disabled extensions: mpd, local, m3u
2019-02-13 19:32:53,340 INFO [13574:MainThread] mopidy.commands: Starting Mopidy mixer: SoftwareMixer
2019-02-13 19:32:53,341 INFO [13574:MainThread] mopidy.commands: Starting Mopidy audio
2019-02-13 19:32:53,341 INFO [13574:MainThread] mopidy.commands: Starting Mopidy backends: StreamBackend, FileBackend, SpotifyBackend
2019-02-13 19:32:53,351 INFO [13574:Audio-2] mopidy.audio.actor: Audio output set to “autoaudiosink”
2019-02-13 19:32:53,404 INFO [13574:MainThread] mopidy.commands: Starting Mopidy core
2019-02-13 19:32:53,408 INFO [13574:SpotifyEventLoop] spotify.session: Spotify logged in
2019-02-13 19:32:53,408 INFO [13574:SpotifyEventLoop] mopidy_spotify.backend: Logged in to Spotify in offline mode
2019-02-13 19:32:53,414 INFO [13574:MainThread] mopidy.commands: Starting Mopidy frontends: HttpFrontend
2019-02-13 19:32:53,415 INFO [13574:MainThread] mopidy.commands: Starting GLib mainloop
2019-02-13 19:32:53,415 INFO [13574:HttpFrontend-10] mopidy.http.actor: HTTP server running at [::]:6680
2019-02-13 19:32:53,689 INFO [13574:SpotifyEventLoop] mopidy_spotify.backend: Logged in to Spotify in online mode

Logs are good, nmap?

nmap localhost

Starting Nmap 7.60 ( https://nmap.org ) at 2019-02-13 19:45 UTC
Nmap scan report for localhost (127.0.0.1)
Host is up (0.000012s latency).
Other addresses for localhost (not scanned): ::1
rDNS record for 127.0.0.1: localhost.localdomain
Not shown: 999 closed ports
PORT STATE SERVICE
22/tcp open ssh

Nmap done: 1 IP address (1 host up) scanned in 1.64 seconds

Womp womp, no errors, no port opening, what am I missing?


#2

Is Mopidy’s port in nmap’s default list of 1000 ports to scan? If you can show curl is unable to connect to localhost:6680 I’d be more inclined to believe there is a problem here.