Mopidy Discourse

How to install mopidy-muse on rpi3b+

I installed with apt on RpiOSlite and noticed pip wasn’t installed, so I installed it with sudo apt install python3-pip then installed muse with python3 -m pip install Mopidy-Muse and enabled the mopidy service with systemd and configured muse here /etc/mopidy/mopidy.conf with:

[muse]
enabled = true
# the following are optional values
mopidy_host = localhost
mopidy_port = 6680
mopidy_ssl = false
snapcast_host = localhost
snapcast_port = 1780
snapcast_ssl = false

now sudo mopidyctl config says:

Running "/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config" as user mopidy
WARNING  [MainThread] mopidy.config Ignoring config section 'muse' because no matching extension was found
...

As muse is in the offical addon list I think it should work like this.
What am I doing wrong?

Use sudo mopidyctl deps to show everything that’s been found.

You probably need to do sudo python3 -m pip install Mopidy-Muse

Thanks, that changed something, I first did deps:

pi@mopidy:~ $ sudo mopidyctl deps
Running "/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf deps" as user mopidy
WARNING  [MainThread] mopidy.config Ignoring config section 'muse' because no matching extension was found
Executable: /usr/bin/mopidy
Platform: Linux-5.10.52-v7+-armv7l-with-debian-10.10
Python: CPython 3.7.3 from /usr/lib/python3.7
Mopidy: 3.2.0 from /usr/lib/python3/dist-packages
Mopidy-MPD: 3.1.0 from /usr/lib/python3/dist-packages
GStreamer: 1.14.4.0 from /usr/lib/python3/dist-packages/gi
  Detailed information: 
    Python wrapper: python-gi 3.30.4
    Relevant elements:
      Found:
        uridecodebin
        souphttpsrc
        appsrc
        alsasink
        osssink
        oss4sink
        pulsesink
        id3demux
        id3v2mux
        lamemp3enc
        mpegaudioparse
        mpg123audiodec
        vorbisdec
        vorbisenc
        vorbisparse
        oggdemux
        oggmux
        oggparse
        flacdec
        flacparse
        shout2send
      Not found:
        flump3dec
        mad

then installed as suggested (I could swear I did it already exactly same again, but it really loaded something more…):

pi@mopidy:~ $ sudo python3 -m pip install Mopidy-Muse
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting Mopidy-Muse
  Downloading https://files.pythonhosted.org/packages/75/c3/44ea8709adcccffb49192371e554c313f85bdb19cb329637aae0b6820e3b/Mopidy_Muse-0.0.27-py3-none-any.whl (300kB)
    100% |████████████████████████████████| 307kB 718kB/s 
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from Mopidy-Muse) (40.8.0)
Requirement already satisfied: Pykka>=2.0.1 in /usr/lib/python3/dist-packages (from Mopidy-Muse) (2.0.3)
Requirement already satisfied: Mopidy>=3.0.0 in /usr/lib/python3/dist-packages (from Mopidy-Muse) (3.2.0)
Installing collected packages: Mopidy-Muse
Successfully installed Mopidy-Muse-0.0.27
pi@mopidy:~ $ sudo mopidyctl deps
Running "/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf deps" as user mopidy
Executable: /usr/bin/mopidy
Platform: Linux-5.10.52-v7+-armv7l-with-debian-10.10
Python: CPython 3.7.3 from /usr/lib/python3.7
Mopidy: 3.2.0 from /usr/lib/python3/dist-packages
Mopidy-MPD: 3.1.0 from /usr/lib/python3/dist-packages
Mopidy-Muse: 0.0.27 from /usr/local/lib/python3.7/dist-packages
  Pykka: 2.0.3 from /usr/lib/python3/dist-packages
  setuptools: 40.8.0 from /usr/lib/python3/dist-packages
  Mopidy: 3.2.0 from /usr/lib/python3/dist-packages
GStreamer: 1.14.4.0 from /usr/lib/python3/dist-packages/gi
  Detailed information: 
    Python wrapper: python-gi 3.30.4
    Relevant elements:
      Found:
        uridecodebin
        souphttpsrc
        appsrc
        alsasink
        osssink
        oss4sink
        pulsesink
        id3demux
        id3v2mux
        lamemp3enc
        mpegaudioparse
        mpg123audiodec
        vorbisdec
        vorbisenc
        vorbisparse
        oggdemux
        oggmux
        oggparse
        flacdec
        flacparse
        shout2send
      Not found:
        flump3dec
        mad
pi@mopidy:~ $ sudo reboot
Connection to mopidy.local closed by remote host.
Connection to mopidy.local closed.

But the muse frontend is not reachable on port 80.
Do i have to enable autostart for muse as well?

Access is on port 6680 for Mopidy Web frontends.

Also, on port 6680 no response.
Do I have to activate a frontend like muse manual, or should it start with mopidy if it is listed as add-on?

Share your full sudo mopidyctl config and ensure you’ve read the http extension documentation, especially the hostname setting.

I tried the http://:6680 way. Does that still involve the hostname setting you mention?

$ sudo mopidyctl config
Running "/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config" as user mopidy
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
verbosity = 0
format = %(levelname)-8s [%(threadName)s] %(name)s %(message)s
color = false
config_file =

[audio]
mixer = software
mixer_volume = 
output = autoaudiosink
buffer_time = 

[proxy]
scheme = 
hostname = 
port = 
username = 
password = 

[muse]
enabled = true
mopidy_host = localhost
mopidy_port = 6680
mopidy_ssl = false
snapcast_host = localhost
snapcast_port = 1780
snapcast_ssl = false

[file]
enabled = true
media_dirs = 
  $XDG_MUSIC_DIR|Music
  ~/|Home
excluded_file_extensions = 
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .pdf
  .png
  .txt
  .zip
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[http]
enabled = true
hostname = 127.0.0.1
port = 6680
zeroconf = Mopidy HTTP server on $hostname
allowed_origins = 
csrf_protection = true
default_app = mopidy

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

[softwaremixer]
enabled = true

[stream]
enabled = true
protocols = 
  http
  https
  mms
  rtmp
  rtmps
  rtsp
metadata_blacklist = 
timeout = 5000

[mpd]
enabled = true
hostname = 127.0.0.1
port = 6600
password = 
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = 
  listall
  listallinfo
default_playlist_scheme = m3u

@kingosticks can you help me here? Do you see anything suspicious?

If you are trying to access the frontend from a machine other than the pi you installed Mopidy on then your hostname setting is wrong. There is a big note about exactly this in the http extension documentation.