Hifiberry Digi+


did anyone get the Hifiberry Digi+ working with Mopidy (not musicbox!)? I tried different configurations but nothing worked - no sound output!

What are the correct configurations for the soundcard? My soundcard works good, I can play music via:

aplay “any mp3”

but not in mopidy…

edit: okay forget it. I just rebooted and it worked…

mixer = software
output = alsasink

I’, trying now for a couple of days, but can’t get it to work in Mopidy, I run it on an OSMC image. The sound works fine on an MusicBox image, the sound works in Kodi, the sound works from SSH but I can’t get audio over the hifiberry with Mopidy.

Help? Tips?

Did you follow the guide for your kernel at the hifiberry website? Specifically, does `aplay -l’ only show yourthe hifiberry card or also the onboard one?

Yes I did follow multiple guides and none of them gave the right result, the hifiberry is the only card shown on my rasp

Is the digi+ the one with 2 outputs - how many devices are listed for the card in the output of aplay -l? If there are multiple devices, have you tried explicitly setting the device in your mopidy config? e.g.

output = alsasink device=hw:0,x

Where x is the device number.