Mopidy as a service does not start with Hifiberry DAC as sound output

Hi all,

I hope I find a answer here. So far I’ve managed to install mopidy and configure a local USB drive to be accessible via the Musicbox webclient. So far so good.
My Raspberry has a Hifiberry DAC installed on it (not die Dac+ version)
I’ve just tested the general functionality of the DAC and it works fine, playback of a WAV file was successfull.
It is visible via aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

My audio output is set to:

output = hifiberry_dac

When starting the service via sudo service mopidy start it always fails at the audio output which shows the following error.

Apr 15 20:51:00 raspberrypi mopidy[18534]: ERROR Failed to create audio output “hifiberry_dac”: gst_parse_error: no element “hifiberry_dac” (1)

I really don’t have any idea what I have to change to make this working…

Please tell me what additional information you need to troubleshoot this. At least the DAC is working fine but I couldn’t manage to get it running with mopidy.

Are you using pimusicbox here? Because output = hifiberry_dac is a specific pimusicbox configuration setting and not appropriate to set for the audio/output mopidy config setting. You would just set alsasink or autoaudiosink or leave it as default as per the Mopidy documentation.

I’m using mopidy on top of raspbian. And I’ve installed the mopidy musicbox webclient for normal webaccess.
Pimusicbox is the standalone version, is it?

I will give it a try. Could be possible that I’ve misunderstood something in while reading trough this stuff.


I think so, I don’t think it says anywhere to set output = hifiberry_dac. If you just set output = alsasink, it should just work.

Thank you, it just started without an error.

But now I have another problem :confused:

Now I have the problem that I’m able to browse trough the mounted USB device on my PI but it can not play the files…
log says the following.

2017-04-15 21:39:10,469 WARNING [21199:FileBackend-5] mopidy.file.library: Failed looking up file:///media/USB/Alligatoah/Musik%20ist%20keine%20Loesung/Alligatoah%20-%$
2017-04-15 21:39:20,664 WARNING [21199:Audio-2] Setting GStreamer state to GST_STATE_PLAYING failed
2017-04-15 21:39:20,681 WARNING [21199:Core-7] mopidy.core.tracklist: Track is not playable: file:///media/USB/Alligatoah/Musik%20ist%20keine%20Loesung/Alligatoah%20-%$

It doesn’t think the track is playable, it’s not clear what sort of file that is but perhaps you need to install some more gstreamer plugins. make sure you have these three, at least:

  • gstreamer1.0-plugins-good
  • gstreamer1.0-plugins-bad
  • gstreamer1.0-plugins-ugly

thanks for your answer. I think it could be possible that the permissions on these MP3’s are just not correctly set as these are NTFS. I know it is possible to also handle NTFS filesystems but I’ve changed the filesystem on the USB-Stick to exFat. Hope that fixed the issue, but for now I’am not really able to test this as we are currently on the move.
I will definitely give an update on this.
If anyone has any another idea I would really appreciate :slight_smile: