GStreamer encountered a general supporting library error

I had some trouble getting to work a local radio stream using Pi MusicBox. Since it took me a while to figure out, how to make it work, I document my workaround for others that may run into the same issue:

On the Radiopage of Pi MusicBox I entered this streaming URL, but nothing happened:
A look at /var/log/mopidy/mopidy.log revealed this error:

2014-09-14 12:29:31,682 - WARNING  Problem looking up GStreamer encountered a general supporting library error.

I searched the web, but did not find useful information.
I also tried other *.m3u resources, e.g., which worked well.
I downloaded the m3u file using Firefox and checked its content:


#EXTINF:-1,Fritz vom rbb live hören -
#EXTINF:-1,Fritz vom rbb live hören -
#EXTINF:-1,Fritz vom rbb live hören -

When I entered any of these URLs listed within the m3u file, the stream played well in Pi MusicBox.
Of course, if the content of changes, I wouldn’t notice until streaming fails again.

I am not sure, what breaks GStreamer. The m3u file at also defines #EXTM3U and #EXTINF settings, but works well. Maybe it is the German umlaut ö in the #EXTINF statements.

Hope this might be helpful for others.


What version of MusicBox do you use? 0.5 should support m3u. Otherwise you could file a bug at the github of mopidy.

Hi Wouter,
thank you for your reply.
Yes, it is 0.5. And, yes, support for m3u is provided. As I mentioned, other m3u files work. It is, which does not work. Does it work for you?

I got this URL from the ubuntuusers wiki, but it is also listed on this radio station’s official website.
I could imagine that the umlaut in #EXTINF is the issue here.

Should I file a bug with Mopidy or rather GStreamer?
Thank you,

The m3u handling is Mopidy specific, so please file a bug with our project :slight_smile:

Thank you. I filed a new bug at github.