Flick HAT not working


#1

Hey, I want to control volume with Flick HAT on my Pi MusicBox, but how to install it?

Problem:

root@MusicBox:~# flick-demo
Traceback (most recent call last):
File "/usr/local/bin/flick-demo", line 4, in <module>
  __import__('pkg_resources').run_script('flicklib==0.0.1', 'flick-demo')
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 664, in run_script
  self.require(requires)[0].run_script(script_name, ns)
File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 1451, in run_script
  exec(script_code, namespace, namespace)
File "/usr/local/lib/python2.7/dist-packages/flicklib-0.0.1-py2.7.egg/EGG-INFO/scripts/flick-demo", line 4, in <module>
  __import__('pkg_resources').run_script('flicklib==0.0.1', 'flick-demo')
File "build/bdist.linux-armv7l/egg/flicklib.py", line 39, in <module>
File "build/bdist.linux-armv7l/egg/i2c.py", line 118, in __init__
OSError: [Errno 2] No such file or directory: '/dev/i2c-1'

Pi MusicBox version 0.7.0RC7


#2

Maybe you need to enable the i2c overlay in /boot/config.txt. I have no experience with this hat.


#3

How to enable it? Do you think about dtparam=i2c_arm=on?


#4

Your guess (or googling) is as good as mine.


#5

Okay, but it still didn’t work.