No Youtube Audio

I’m a newb to linux and all things Raspberry Pi and I love Musicbox it does almost everything I want it to! But I am struggling to get Youtube streams to play, searching youtube allows me to add streams to the queue but when they play there is no sound and the playback slider moves to around 6 seconds and then goes back to 0.

I have tried updating mopidy-youtube but this stops my access to the webclient completely and I get a Connection Refused or page cannot be displayed error in my browser.

I have also tried as the mopidy-youtube git suggests installing pfay

Youtube also shows up in my config set to true but it does not show in the list when i run ‘mopidy deps’

sorry if this question has been answered somewhere else, but any help would be much appreciated.


I’ve actually noticed the same problem recently with the most recent
versions of everything (musicbox is still using an older version right now
and updating is not possible). I’m not sure exactly what’s wrong, the
streams themselves play fine outside of mopidy, it needs further debugging.

1 Like

I had a similar problem with Spotify, it would play fine for a long time then suddenly stop, but in the now playing window it would run from 0 to 8 or so seconds, then go back to zero and get stick in loop on that track. I could go forward and it would play next track, go back and it would play previous. In the end I put it down to poor WiFi connection as when connected by cable I didn’t get the problem. Have now moved the pi nearer the router and gone irelessand haven’t had problem sonce

Apologies for spelling in previous post I’m trying to get to grips with new phone.

The problem I saw was specifically youtube and when using a wired
connection (on a pc). And there is no looping, there is never any youtube
audio as all the streams fail to play. So I’m not convinced they are the
same issue.

I’m not sure it is poor internet connection as no audio plays at all from any Youtube stream.

And bizarrely the youtube issue I was having last week has now disappeared. It is working perfectly now, just as it used to. So please disregard what I previously said

@ThatGirlDee: do other backends work for you? i.e. spotify, dirble, tunein?
If you have updated mopidy-youtube then it’s likely already pulled in the latest version of Mopidy which Musicbox doesn’t support (yet). If you are having trouble with that then the easiest way to rescue that is to start over with a fresh Musicbox image and you can copy across your settings.ini.

It’s still worth trying out a wired connection, a lot of issues often boil down to wireless/power issues.

Failing that, please take a look in /var/log/mopidy/mopidy.log for any error messages.

Thanks for your help! Every other backend works as it should, and I have tried a fresh install a few times. I will try using a wired connection and see how it goes.

I have the same problem with youtube, it plays after a while though but the longer the video, the longer it takes befote it plays. The loop becomes longer after a while and when it reaches about 12 seconds it will play good audio quality till the end. Next video in playlist will cause a loop again.

Using raspberry pi 2b with hifiberry digi and musicbox 0.6 fixed that specific issue, so just waiting for pimusicbox to get up to mopidy 1.0 for this fix to be in.


It does sound like it’s buffering doesn’t it. There are a bunch of
different output buffer configurations commented out in settings.ini which
might have some effect it someone is able to play around. Are you using
wired or wireless?

I stand corrected. Thanks @adamcik. I’ll try and step my efforts up a gear and get something based on mopidy v1.x out.

1 Like

I forgot to post an update/fix of my issue. Removing the download flag as described works perfect for me on PiMusicBox


Hi could you please give some instructions on how/where to edit this flag? Do we edit a file on the pi?

Can someone tell me how to apply this fix, removing the download flag. by the looks of it they have changed a load since this fix?

open the following file for editing in your favorite editor:


remove the download flag from PLAYBIN_FLAGS so only the following options remain:

# Default flags to use for playbin: AUDIO, SOFT_VOLUME PLAYBIN_FLAGS = (1 << 1) | (1 << 4) PLAYBIN_VIS_FLAGS = PLAYBIN_FLAGS | (1 << 3)

Save the file and reboot your pi, please note that changing this results in to not being able to seek through the track.

Just wanted to add that the changes in the last post worked perfectly for me.

Before that, it took a minute or two to start playing and then cut out after around another minute of playback.