Error scanning wma files / gstreamer plugin missing


#1

I have installed musicbox 0.5.3 on my pi b. While scanning a network share the following message appears:

WARNING  Failed local:track:Network/path and filename.wma: Your GStreamer installation is missing a plug-in.

I have tried to purge and reinstall gstreamer0.10-ffmpeg - but that does not help.

Thank you very much for any help.


#2

According to codecs wiki i have tried

apt-get install gstreamer0.10-plugins-good
apt-get install gstreamer0.10-plugins-ugly
apt-get install gstreamer0.10-plugins-bad
apt-get install gstreamer0.10-plugins-base
apt-get install libxvidcore4
apt-get install gstreamer0.10-ffmpeg

but the newest version is already installed for each of the above.

Checking the installed codecs:

gst-inspect-0.10 |grep decode |grep wma
ffmpeg:  ffdec_wmapro: FFmpeg Windows Media Audio 9 Professional decoder
ffmpeg:  ffdec_wmav1: FFmpeg Windows Media Audio 1 decoder
ffmpeg:  ffdec_wmav2: FFmpeg Windows Media Audio 2 decoder
ffmpeg:  ffdec_wmavoice: FFmpeg Windows Media Audio Voice decoder

Looks like that the wma codecs are installed?

But trying to play a wma file stil results in an errror:

root@MusicBox:/#  gst-launch-0.10 filesrc location=/tmp/b.wma ! decodebin ! alsasink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Missing element: Windows Media Audio decoder
ERROR: from element /GstPipeline:pipeline0/GstDecodeBin:decodebin0/GstASFDemux:asfdemux0: Internal data stream error.

I have also tried

rm -f /home/mopidy/.gstreamer-0.10/registry.arm.bin

without any result.

Any hint on how to enable wma support would be very nice!


#3

Sadly I have no idea, but I would search for other people trying to get GStreamer on ARM to do WMA. Worst case GStreamer 1.0 might be the fix, but timeline for the switch isn’t quite set yet.


#4

Thx for your answer. Looks like i have to pause this issue for a while, I have spent a couple of days searching a solution - there seenms nobody out there who have gstreamer playing wma on a raspberry.


#5

i had the same problem with wma files with gstreamer1.0 on arm, while having gstreamer0.10-plugins-good/ugly/bad/base installed I had to install gstreamer1.0-libav also and now it is working.