Can't find local media when running as service


I’m trying to run mopidy as a service. I copied my working config from .config/mopidy/mopidy.conf to /etc/mopidy/mopidy.conf. Everything seems to work OK apart from the Browse function which tells me “No tracks found”. I tried re-scanning via the terminal (couldn’t find a way to do it via the interface) and rebooting - still nothing.

Any ideas what’s going on here?

EDIT: forgot to mention that my “local media” is actually an NFS mount (at /media/music/ via an appropriate entry in /etc/fstab). Not sure if that has anything to do with it.


Anyone got any thoughts on this? Sorry for bumping but I’m completely stuck on this issue.


Check the service config is as you expect with ‘sudo service mopidy run
config’. You can start a scan by running ‘sudo service mopidy run local
scan’. If it’s still not working it may be worth checking the permissions
on your data/music etc directories are all OK.

Yes, sorry. I found the docs I was missing a couple of hours ago. My scan just finished and I can see my media now.