Boat Browser / FHEM


I have installed FHEM home automation server (see ) on a raspberry pi and I am using musicbox which is running on a second raspberry pi

For FHEM I am using the boat browser since it offers a nice fullscreen mode and also a screen-always-on-option.

2 questions:

  • I would like to control musicbox directly through FHEM. Anybody here who tried this ? There are fhem modules for Sonos but not for musicbox…

  • any chance to get a musicbox version which runs with my beloved boat browser ? Currently it does not.



Musicbox uses Mopidy which is compatible with most of the MPD protocol. If
your home automaton software supports MPD then you can use that to control

If it works OK in other browsers then you’ll have to find out what’s the
specific problem with boat browser. I’ve never heard of it. does it support
websockets? If not, you could try installing an alternative Web client like


thanks for your help.

FHEM supports MPD and I could make it work.

Best regards



I just tried to install ROMPR using these instructions:

Installation was straight forward (except I had to use nano instead of vi) but
finally I got stuck with that error message.

root@MusicBox:~# service mpd restart
[ ok ] Stopping Music Player Daemon: mpd.
[…] Starting Music Player Daemon: mpdFailed to bind to ‘’: Address already in use

Can you help ?



You want to restart mopidy, so ‘service mopidy restart’.

In fact, mpd should not be installed/running. Musicbox uses Mopidy (which
supports the MPD protocol but is an alternative to the mpd program ).

OK, I downloaded rompr and unzipped it to mentioned directory.
however when I enter in my browser I get a 404 error.
I suppose that the files are in the correct directory (see below) so whats wrong here ? Sorry I am linux novice…



login as: root
root@’s password:

(_____ () () () (
___) ) _ _ _ _ _ ___ _ ____ ) ) ___ _ _
| / | | |||| | | | |/) |/ ) __ ( / _ ( \ / )
| | | | | | | | |
| |
| ( (
| |
) ) |
| ) X (
|| || || ||/(/||____)___/ _(/ _)


root@MusicBox:~# cd /var/www/rompr
root@MusicBox:/var/www/rompr# ls
404.php backends filesearch.php includes jshash-2.2 saveprefs.php utils
INSTALL.txt browser fonts index.php newimages sizes
LICENSE.txt collection getRemoteImage.php international player skins
albumart coversizes getalbumcover.php international.php plugins streamplugins
albumart.php css getid3 iso3166.xml prefs themes
albums.php dirbrowser.php getplaylist.php jquery radios timezones.txt
apache_conf.d favicon.ico iconsets jqueryui1.8.16 resources ui

How did you setup the apache server?
Have you copied /var/www/rompr/apache_conf.d/rompr.conf ?

As root do

cp /var/www/rompr/apache_conf.d/rompr.conf /etc/apache2/sites-available/

edit rompr.conf (nano /etc/apache2/sites-available/rompr.conf

replace every PATH-TO-ROMPR with /var/www/rompr

make sure /var/www/rompr belongs to the user apache is running under. Normally www-data.

chown -R www-data:www-data /var/www/rompr


a2ensite rompr.conf

sevice apache2 restart

Enjoy rompr.


I just tried that everything went fines but
"service apache2 restart2 results in the following:

root@MusicBox:~# service apache2 restart
Syntax error on line 31 of /etc/apache2/sites-enabled/rompr.conf:
Invalid command ‘Header’, perhaps misspelled or defined by a module not included in the server configuration
Action ‘configtest’ failed.
The Apache error log may have more information.

What may be wrong ?

Thanks Ralf

Your Apache config file has a Syntax error at ( or near) line 31.
Most probably you are missing the header module.

a2enmod headers

Ok that helped. The error message is gone.

However when I enter in my browser
I still get that 404 error.

The standard Musicbox website is still accessible at


Could be a couple of issues:

First check the path in the apache configfile matches the location of the rompr code.
Next check the file permissions of the rompr directory. It should belong to the user your apache is running as. Probably www-data (you can check with ‘ps aux | grep apache’ )

Also the apache log and error files may be helpful.



When I enter in my browser,
I get the standard musicbox page which points to
/opt/webclient/index.html must point to /var/www
but it obviously points to /opt/webclient/rompr/
which of course does not exist. should be the apache default
page but a said, this points to the musicbox page.

I noticed now that when I boot the raspberry, points to the apache default page "“it works” for a short moment. After some seconds when reloading the page, the standard musicbox page appears. rompr is not reachable either way

I am not running a musicbox, so it is hard to tell what is going on with you apache configuration.
I assume musicbox has setup a default document root of /opt/webclient.

So you need to move rompr to /opt/webclient/rompr and change the rompr configuration.
And/Or move the musicbox configuration from a default configuration to a specific config file and move the musicbox client from /opt/webclient to /opt/webclient/musicbox.