Webradio playback stopping after some hours

Soo… I’m using Mopidy in the following environment:

  • KDE Neon on NUC, connected via WiFi
  • RompR as frontend, then Mopidy and Pulseaudio

After a reboot I can play webradio for several hours without issue, then suddenly it stops.
/var/log/mopidy/mopidy.log says:
2020-01-12 12:58:13,512 INFO [830:MpdSession-365] mopidy.mpd.session: New MPD connection from [::ffff:]:6600
2020-01-12 12:58:14,578 INFO [830:MpdSession-366] mopidy.mpd.session: New MPD connection from [::ffff:]:6600
2020-01-12 12:58:17,613 INFO [830:MpdSession-367] mopidy.mpd.session: New MPD connection from [::ffff:]:6600
2020-01-12 23:13:05,311 ERROR [830:MainThread] mopidy.audio.gst: GStreamer error: gst-resource-error-quark: A network error occurred, or the server closed the connection unexpectedly. (9)

Any idea where I should start debugging?


The error strongly suggests it’s a network problem. I’d suggest starting by elimiating Wifi from the equation. And also trying other radio streams.

You could also try using something like https://github.com/pimusicbox/mpd-watchdog

Please also take a minute to read https://docs.mopidy.com/en/latest/troubleshooting/.

Thanks for the quick reply! I’ll try it with a LAN cable. Different streams I’ve already tried, same result. I’ll have a look at mpd-watchdog too. And the troubleshooting guide.

It May be a network problem, but mopidy should handle it and try to restart the stream playback. I am also having this error and i need to stóp and then start manually playback.

How to use mpd-watchdog on a Raspberry with mopidy and Iris?

Update: For whatever reason the issue just disappeared. My current radio stream has been running for days without any problem. Weird.