Volume level lower on USB-DAC with Pi Musicbox


I’m planning to replace my HTPC with Pi Musicbox, because I’m lately only playing music via HTPC.

HTPC has Atom-processor based mini-ITX board with Win7, which is connected into Bel Canto e.One S300iu integrated amplifier’s built in USB-DAC. With Pi Musicbox volume level was a lot quieter than output from HTPC. It would be nice to have it same level as HTPC was.

It there some parameter or other trick to increase volume level (gain) on USB-out case? I have set volume to max on Musicbox settings.


You can change the output = ... line in /boot/config/settings.ini to:

output = volume volume=1.2 ! alsasink buffer-time=200000 latency-time=10000

The volume setting there has 0 = 0%, 1.0 = 100%, and can go up to 10 (volume scale is linear).

Not a 100% sure this will work, as there is a chance the code will find this and set the volume to a value between 0-1.0, but if you additionally set mixer= then volume control is disabled and you can probably get the fixed boost to work.

I’m also unsure if this is the right place to solve it. Other option could be .asoundrc settings. And if this is really a digital output there might “not” be any volume per se.

you can also logon to musicbox and run alsamixer
MusicBox tries to initialise USB master volume to 85% or so, but it does not recognize alle names of the USB volume handlers. Something to look into…
After you set the volume in alsamixer, issue this command:
alsactl store