User-level PipeWire with system-level mopidy

Hello, mopidy is unable to produce sound at all. I have narrowed it down to being a system-level vs user-level issue: gst-launch-1.0 audiotestsrc ! autoaudiosink works great while sudo gst-launch-1.0 audiotestsrc ! autoaudiosink returns [ALSOFT] (EE) Failed to connect PipeWire event context (errno: 112) Pipeline is PREROLLING ... WARNING: from element /GstPipeline:pipeline0/GstAutoAudioSink:autoaudiosink0: Failed to connect: Connection refused Additional debug info: ../gstreamer/subprojects/gst-plugins-good/ext/pulse/pulsesink.c(616): gst_pulseringbuffer_open_device (): /GstPulseSink:autoaudiosink0-actual-sink-pulse. I’ve tried Add documentation for running as a user service · Issue #1974 · mopidy/mopidy · GitHub with no success. Help would be appreciated. Thanks!

Did you also follow Running as a service — Mopidy 3.4.2 documentation ?

EDIT: sorry, I mentally replaced pipewire with pulseaudio for some reason. Obviously that pulse doc doesn’t help.

The issue you linked to is the correct setup as far as I know, I have never tried it myself but it makes sense.